summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Jaara2016-03-19 22:52:32 +0200
committerJesse Jaara2016-03-19 22:52:32 +0200
commitda1d42ceefc7d20a72edaa40c08a0894e20805e2 (patch)
tree59169cf38002e1b57f4118664919639eeb367b63
downloadaur-da1d42ceefc7d20a72edaa40c08a0894e20805e2.tar.gz
Init package
-rw-r--r--.SRCINFO16
-rw-r--r--0001-sleep-before-reset.patch11
-rw-r--r--PKGBUILD46
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce3e31fe654c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hciattach-rpi3
+ pkgver = 5.38
+ pkgrel = 1
+ url = http://www.bluez.org/
+ arch = armv7h
+ license = GPL2
+ makedepends = dbus
+ makedepends = libical
+ makedepends = systemd
+ source = http://www.kernel.org/pub/linux/bluetooth/bluez-5.38.tar.xz
+ source = 0001-sleep-before-reset.patch
+ sha256sums = 0618c5440be6715805060ab5eea930526f34089c437bf61819447b160254f4df
+ sha256sums = 788472529eec5e5d5e5db95727c072bde868a509f4092171d35b7bf78bf81390
+
+pkgname = hciattach-rpi3
+
diff --git a/0001-sleep-before-reset.patch b/0001-sleep-before-reset.patch
new file mode 100644
index 000000000000..9120e69d94e5
--- /dev/null
+++ b/0001-sleep-before-reset.patch
@@ -0,0 +1,11 @@
+diff -Naur bluez-5.38/tools/hciattach_bcm43xx.c bluez-5.38-patched/tools/hciattach_bcm43xx.c
+--- bluez-5.38/tools/hciattach_bcm43xx.c 2015-03-11 12:01:57.000000000 +0200
++++ bluez-5.38-patched/tools/hciattach_bcm43xx.c 2016-03-19 21:56:11.485964208 +0200
+@@ -380,6 +380,7 @@
+ return -1;
+ }
+
++ sleep(1);
+ if (bcm43xx_reset(fd))
+ return -1;
+ }
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72fd06582980
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Jesse Jaara <gmail.com: jesse.jaara>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
+
+pkgname=hciattach-rpi3
+pkgver=5.38
+pkgrel=1
+url="http://www.bluez.org/"
+arch=('armv7h')
+license=('GPL2')
+makedepends=('dbus' 'libical' 'systemd')
+source=(http://www.kernel.org/pub/linux/bluetooth/bluez-${pkgver}.tar.xz
+ 0001-sleep-before-reset.patch)
+sha256sums=('0618c5440be6715805060ab5eea930526f34089c437bf61819447b160254f4df'
+ '788472529eec5e5d5e5db95727c072bde868a509f4092171d35b7bf78bf81390')
+
+prepare() {
+ cd "bluez-${pkgver}"
+
+ patch -Np1 -i ../0001-sleep-before-reset.patch
+}
+
+build() {
+ cd "bluez-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --enable-sixaxis \
+ --enable-experimental \
+ --enable-library # this is deprecated
+
+ make tools/hciattach
+}
+
+package() {
+ cd "bluez-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mv tools/hciattach "${pkgdir}/usr/bin/hciattach-rpi3"
+}
+