summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCubeTheThird2020-01-27 23:57:08 -0500
committerCubeTheThird2020-01-27 23:57:08 -0500
commitda5e567ff2c9ce4908183dbbc01c128228c15180 (patch)
treed885c584b1e16e1edc1e3b8b689baf7be198a451
parent7af0b8f2735bfe8cc87d9f7a4e2e351309bd93ac (diff)
downloadaur-da5e567ff2c9ce4908183dbbc01c128228c15180.tar.gz
Using new DATADIR option for multi-user support.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 222babff4ce5..ece4cecece71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brogue-ce-git
pkgdesc = Brogue Community Edition: A 26-level dungeon crawl to the Amulet of Yendor.
- pkgver = 1.8.r13.gac3d50b
- pkgrel = 2
+ pkgver = 1.8.1.r0.g9f9254d
+ pkgrel = 1
url = https://github.com/tmewett/BrogueCE
arch = i686
arch = x86_64
@@ -9,9 +9,7 @@ pkgbase = brogue-ce-git
makedepends = git
depends = sdl2_image
source = brogue-ce-git::git+https://github.com/tmewett/BrogueCE.git
- source = brogue.sh
md5sums = SKIP
- md5sums = 38dc6a1ba7f29decb26a5745784341b3
pkgname = brogue-ce-git
diff --git a/PKGBUILD b/PKGBUILD
index f46cc1b0fd7a..dcb54e7df4ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,16 @@
#Maintainer: CubeTheThird <cubethethird@gmail.com>
pkgname=brogue-ce-git
-pkgver=1.8.r13.gac3d50b
-pkgrel=2
+pkgver=1.8.1.r0.g9f9254d
+pkgrel=1
pkgdesc="Brogue Community Edition: A 26-level dungeon crawl to the Amulet of Yendor."
arch=('i686' 'x86_64')
url="https://github.com/tmewett/BrogueCE"
license=('AGPL3')
depends=('sdl2_image')
makedepends=('git')
-source=(brogue-ce-git::"git+https://github.com/tmewett/BrogueCE.git"
- 'brogue.sh')
-md5sums=('SKIP'
- '38dc6a1ba7f29decb26a5745784341b3')
+source=(brogue-ce-git::"git+https://github.com/tmewett/BrogueCE.git")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
@@ -23,22 +21,24 @@ build() {
cd "$srcdir/$pkgname"
make clean
- make
+ make DATADIR="/opt/${pkgname}"
- ./make-link-for-desktop.sh > /dev/null
+ cd linux
+ ./make-link-for-desktop.sh > /dev/null
sed -i -e "s|$(pwd)|/opt/${pkgname}|" -e 's/brogue$/brogue.sh/' -e 's/bin\///' "brogue.desktop"
+ sed -i -e "s|/opt/brogue|/opt/${pkgname}|" -e "s|local/share/Brogue|local/share/${pkgname}|" brogue-multiuser.sh
}
package() {
cd "$srcdir/$pkgname"
- install -Dm644 brogue.desktop "$pkgdir/usr/share/applications/brogue.desktop"
+ install -Dm644 "linux/brogue.desktop" "$pkgdir/usr/share/applications/${pkgname}.desktop"
_dest_dir="$pkgdir/opt/$pkgname"
mkdir -p "$_dest_dir/assets"
- install -Dm755 "$srcdir/brogue.sh" "$_dest_dir"
+ install -Dm755 "linux/brogue-multiuser.sh" "$_dest_dir"
cd bin/
@@ -47,5 +47,5 @@ package() {
install -Dm644 assets/* "$_dest_dir/assets"
mkdir -p $pkgdir/usr/bin
- ln -s "/opt/${pkgname}/brogue.sh" "$pkgdir/usr/bin/$pkgname"
+ ln -s "/opt/${pkgname}/brogue-multiuser.sh" "$pkgdir/usr/bin/$pkgname"
}