summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Korpel2015-07-07 16:01:47 +0200
committerMarcel Korpel2015-07-07 16:01:47 +0200
commitda637ebee8d66fc4d3f0de6ae2eca123b6a65b04 (patch)
tree1567a114aef853753bc0e43395ce1efb80c690bf
downloadaur-da637ebee8d66fc4d3f0de6ae2eca123b6a65b04.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--fourier-making-waves.sh2
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0df5cd634c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fourier-making-waves
+ pkgdesc = An educational tool for making and exploring waves
+ pkgver = 3.06
+ pkgrel = 1
+ url = http://phet.colorado.edu/en/simulation/fourier
+ arch = any
+ license = GPL2
+ depends = java-runtime
+ depends = sh
+ noextract = fourier_en.jar
+ source = http://phet.colorado.edu/sims/fourier/fourier_en.jar
+ source = fourier-making-waves.sh
+ sha256sums = 5ea7978223de7f493c2ba04fcb7dbfebba7f36aa7c9bb47e1edf817845d34397
+ sha256sums = 00a2543a5a894196dce3225aad45744029b12852cc23bd7d433b2b3646805349
+
+pkgname = fourier-making-waves
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..451fef1da44a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Marcel Korpel <marcel[dot]korpel[at]gmail>
+
+pkgname=fourier-making-waves
+pkgver=3.06
+pkgrel=1
+pkgdesc='An educational tool for making and exploring waves'
+arch=('any')
+url="http://phet.colorado.edu/en/simulation/fourier"
+license=('GPL2')
+depends=('java-runtime' 'sh')
+source=(http://phet.colorado.edu/sims/fourier/fourier_en.jar
+ ${pkgname}.sh)
+noextract=(fourier_en.jar)
+sha256sums=('5ea7978223de7f493c2ba04fcb7dbfebba7f36aa7c9bb47e1edf817845d34397'
+ '00a2543a5a894196dce3225aad45744029b12852cc23bd7d433b2b3646805349')
+
+package() {
+ cd "$srcdir"
+
+ install -Dm644 fourier_en.jar "${pkgdir}/usr/share/java/${pkgname}/fourier_en.jar"
+ install -D ${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/fourier-making-waves.sh b/fourier-making-waves.sh
new file mode 100644
index 000000000000..9ca1390e5b9b
--- /dev/null
+++ b/fourier-making-waves.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "$JAVA_HOME/bin/java" -jar '/usr/share/java/fourier-making-waves/fourier_en.jar' "$@"