summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastien Duthil2019-02-03 22:34:46 -0500
committerSebastien Duthil2019-02-03 22:34:51 -0500
commitda7a94e193f32e237ce83b8c96cebc44baf236de (patch)
treea7eae34761a80c5986b4d82af16d5afb71cf054f
parentadc1eaf2e4c0bf9cc765dc5b5b3a9a8207181abf (diff)
downloadaur-da7a94e193f32e237ce83b8c96cebc44baf236de.tar.gz
fix compilation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--blackvoxel.patch11
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c113d4673e00..8857d19e7f7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = blackvoxel
pkgdesc = Game of automation and programming in a voxel world
pkgver = 2.31
- pkgrel = 1
+ pkgrel = 2
url = http://www.blackvoxel.com/
install = blackvoxel.install
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = blackvoxel
depends = mesa
depends = sdl
source = blackvoxel_source_2_31.tar.bz2::http://www.blackvoxel.com//dm_download.php?file=139&key=1
+ source = blackvoxel.patch
sha256sums = 09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4
+ sha256sums = 5423a426434498480abe47a18ef10a11d8ee99fca8d2d05aec070814ccd6628a
pkgname = blackvoxel
diff --git a/PKGBUILD b/PKGBUILD
index b561d1cb46b6..879ccef93ff7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,22 @@
pkgname=blackvoxel
pkgver=2.31
-pkgrel=1
+pkgrel=2
pkgdesc="Game of automation and programming in a voxel world"
arch=('x86_64')
url='http://www.blackvoxel.com/'
license=('GPL3')
depends=('glew' 'hicolor-icon-theme' 'mesa' 'sdl')
install="${pkgname}.install"
-source=("${pkgname}_source_2_31.tar.bz2::${url}/dm_download.php?file=139&key=1")
-sha256sums=('09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4')
+source=("${pkgname}_source_2_31.tar.bz2::${url}/dm_download.php?file=139&key=1"
+ "blackvoxel.patch")
+sha256sums=('09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4'
+ '5423a426434498480abe47a18ef10a11d8ee99fca8d2d05aec070814ccd6628a')
+
+prepare() {
+ # Disable #include glext. Should be already included by glew.
+ patch "${srcdir}/${pkgname}_source_2_31/src/main.cpp" "${srcdir}/blackvoxel.patch"
+}
build() {
cd "${srcdir}/${pkgname}_source_2_31"
diff --git a/blackvoxel.patch b/blackvoxel.patch
new file mode 100644
index 000000000000..eb58d8b64cea
--- /dev/null
+++ b/blackvoxel.patch
@@ -0,0 +1,11 @@
+--- src/main.cpp 2019-02-03 22:27:48.869873390 -0500
++++ src/main.cpp 2019-02-03 22:27:56.200051727 -0500
+@@ -25,7 +25,7 @@
+ #else
+ # include <GL/glew.h>
+ // # include <GL/gl.h>
+-# include <GL/glext.h>
++// # include <GL/glext.h>
+ // # include <GL/glut.h>
+ #endif
+ #include "SDL/SDL.h"