summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2017-09-28 14:29:13 +0200
committerXZS2017-09-28 14:34:28 +0200
commitda90fd9c90aafe0bb4682a04f6ac30bb3d504aa8 (patch)
tree1005a4fd1b21759dbfa6e42039849045bc7a3802
parentc069cac4d89d9bbf3c5a33027d3d4583f7c08fd2 (diff)
downloadaur-da90fd9c90aafe0bb4682a04f6ac30bb3d504aa8.tar.gz
locally install and compile schema
An intermediary commit removed the ability to find the schema when it is installed in the global location /usr/share/glib-2.0/schemas. Now, only a schema subdirectory in the extension root is examined. This may be an overeager side effect: The respective commit comment talks about fixing translations instead, which continue to be loaded from the global location /usr/share/locale. Nonetheless, the schema has to be installed and compiled inside the extension directory now, which is what the install directives normally do. Only the post-installations script now has to be patched to compile the installed schema despite a DESTDIR set to $pkgdir.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10e438e29a0c..5ea54633d940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-mediaplayer-git
pkgdesc = A mediaplayer indicator for the Gnome Shell
pkgver = 3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/JasonLG1979/gnome-shell-extensions-mediaplayer
install = gschemas.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index dc121c493836..a60cc8a9603b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gnome-shell-extension-mediaplayer-git
pkgver=3.0
-pkgrel=1
+pkgrel=2
pkgdesc='A mediaplayer indicator for the Gnome Shell'
arch=('any')
url='https://github.com/JasonLG1979/gnome-shell-extensions-mediaplayer'
@@ -33,10 +33,11 @@ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- sed -i \
- "/^SCHEMA_DIR/s/EXTENSION_DIR/$(
- )get_option('prefix'), get_option('datadir'), 'glib-2.0'/" \
- "$_gitname"/meson.build
+ sed -i "
+ /^if/s/not//
+ /DATA_DIR =/s/$/[1:]/
+ /^EXTENSION_DIR =/s/path\\.join(/&DEST_DIR,/
+ " "$_gitname"/meson_post_install.py
}
build() {