summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLevi Zhang2022-12-20 21:54:18 +0000
committerLevi Zhang2022-12-20 21:54:18 +0000
commitdaad7974c5c02b44208045f58b6c03002a747796 (patch)
treec045c77fa74b1ef8fcf8090feeaf39294e21ec99
downloadaur-daad7974c5c02b44208045f58b6c03002a747796.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--bin86-0.16.17-aarch64-1.patch44
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2be985037b4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bin86
+ pkgdesc = A complete 8086 assembler and loader for host aarch64
+ pkgver = 0.16.21
+ pkgrel = 4
+ url = https://v3.sk/~lkundrak/dev86/
+ arch = aarch64
+ license = GPL
+ depends = glibc
+ source = https://sources.archlinux.org/other/community/dev86/bin86-0.16.21.tar.gz
+ source = bin86-0.16.17-aarch64-1.patch
+ sha256sums = 021e37cde3a20632c4c9000993cb4aa9f58cb82b1d3c26b9aeb62d6566925738
+ sha256sums = 21fd4fc7cd5823010dbaad31029cf763b5ae94c0d44cf0eea21560e091ac207b
+
+pkgname = bin86
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f0a7c91441e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Huayu Zhang<zhanghuayu.dev@gmail.com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=bin86
+pkgver=0.16.21
+pkgrel=4
+pkgdesc='A complete 8086 assembler and loader for host aarch64'
+arch=('aarch64')
+license=('GPL')
+url='https://v3.sk/~lkundrak/dev86/'
+depends=('glibc')
+source=("https://sources.archlinux.org/other/community/dev86/${pkgname}-${pkgver}.tar.gz"
+ 'bin86-0.16.17-aarch64-1.patch')
+sha256sums=('021e37cde3a20632c4c9000993cb4aa9f58cb82b1d3c26b9aeb62d6566925738'
+ '21fd4fc7cd5823010dbaad31029cf763b5ae94c0d44cf0eea21560e091ac207b')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -Np1 < ../bin86-0.16.17-aarch64-1.patch
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ make PREFIX=/usr
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -d "${pkgdir}"/usr/{bin,share/man/man1}
+ make PREFIX="${pkgdir}"/usr MANDIR="${pkgdir}"/usr/share/man/man1 install
+}
diff --git a/bin86-0.16.17-aarch64-1.patch b/bin86-0.16.17-aarch64-1.patch
new file mode 100644
index 000000000000..8932dba9acbd
--- /dev/null
+++ b/bin86-0.16.17-aarch64-1.patch
@@ -0,0 +1,44 @@
+Submitted By: Ken Moffat <ken@kenmoffat.uklinux.net>
+Date: 2005-06-28
+Initial Package Version: 0.16.14
+Upstream Status: Submitted Upstream
+Origin: from ROCK Linux
+Description: Allows bin86 to compile on x86_64, which permits lilo to
+ be used in a 64-bit system. I'm dubious about ROCK's attempts to
+ automatically add dual-licensing to all their patches, but bin86 is
+ already GPL'd. I've heard from the maintainer that this will be
+ included in the next upload.
+
+
+# --- ROCK-COPYRIGHT-NOTE-BEGIN ---
+#
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+# Please add additional copyright information _after_ the line containing
+# the ROCK-COPYRIGHT-NOTE-END tag. Otherwise it might get removed by
+# the ./scripts/Create-CopyPatch script. Do not edit this copyright text!
+#
+# ROCK Linux: rock-src/package/x86/bin86/x86_64.patch
+# ROCK Linux is Copyright (C) 1998 - 2005 Clifford Wolf
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+#
+# --- ROCK-COPYRIGHT-NOTE-END ---
+
+diff -urN bin86-0.16.14-orig/ld/x86_aout.h bin86-0.16.14/ld/x86_aout.h
+--- bin86-0.16.14-orig/ld/x86_aout.h 2004-11-07 20:07:31.506442000 +0100
++++ bin86-0.16.14/ld/x86_aout.h 2004-11-07 20:07:41.106982496 +0100
+@@ -12,6 +12,9 @@
+ #if defined(i386) || defined(__BCC__) || defined(MSDOS)
+ typedef long Long;
+ #define __OUT_OK 1
++#elif defined(__aarch64__)
++typedef int Long;
++#define __OUT_OK 1
+ #else
+ typedef char Long[4];
+ #endif