summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-11-05 20:57:31 +0000
committerGeorge Rawlinson2021-11-05 20:57:31 +0000
commitdab26211bd306c401fa814c4c214b5a53e0e0eb4 (patch)
tree530a8afb39980c254913f9f30f39fefe1570b5cb
parentc2b89e19acf30605b37f7323083b7372c451b7a0 (diff)
downloadaur-dab26211bd306c401fa814c4c214b5a53e0e0eb4.tar.gz
upgpkg: python-flake8-pytest-style 1.5.1-1
* New upstream release. * Build with python-build instead of python-poetry.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b59cbbd0f348..e46fcd320ca1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = python-flake8-pytest-style
pkgdesc = A flake8 extension that checks issues with pytest tests
- pkgver = 1.5.0
+ pkgver = 1.5.1
pkgrel = 1
url = https://github.com/m-burst/flake8-pytest-style
arch = any
license = MIT
checkdepends = python-pytest-deadfixtures
+ makedepends = python-build
+ makedepends = python-poetry-core
makedepends = python-pip
- makedepends = python-poetry
depends = python
depends = flake8
depends = python-flake8-plugin-utils
- source = python-flake8-pytest-style-1.5.0.tar.gz::https://github.com/m-burst/flake8-pytest-style/archive/v1.5.0.tar.gz
- b2sums = 7e48abc6ec45fde6a59e37cf77015cb640629a2af97bea7976e073457e97f59594d0cdd268119053433083af03f3756709b485dee4674ea3ada4bfc4811803c4
+ source = python-flake8-pytest-style-1.5.1.tar.gz::https://github.com/m-burst/flake8-pytest-style/archive/v1.5.1.tar.gz
+ sha512sums = f961bf8d5c9391959dcb8615963937b824f11586de7c66306b4654e444ef28cb389966582b9daffb356747c58cae057964a7641204f58f3c6b2ede3af1deb1c3
+ b2sums = 66fde40cb2f54954f2ca279c9dbedee1eb9942728ade58ea2943f698565b705cacd825e7002b3226d84deac5cf6a8ced1a54999fb1c6e24c2b9664053c1b2cf0
pkgname = python-flake8-pytest-style
diff --git a/PKGBUILD b/PKGBUILD
index 5f7321dbf9e3..6cd90c84b6cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
pkgname=python-flake8-pytest-style
_pkgname="${pkgname#python-}"
_name="${_pkgname/-/_}"
-pkgver=1.5.0
+pkgver=1.5.1
pkgrel=1
pkgdesc="A flake8 extension that checks issues with pytest tests"
arch=('any')
url="https://github.com/m-burst/flake8-pytest-style"
license=('MIT')
depends=('python' 'flake8' 'python-flake8-plugin-utils')
-makedepends=('python-pip' 'python-poetry')
+makedepends=('python-build' 'python-poetry-core' 'python-pip')
checkdepends=('python-pytest-deadfixtures')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-b2sums=('7e48abc6ec45fde6a59e37cf77015cb640629a2af97bea7976e073457e97f59594d0cdd268119053433083af03f3756709b485dee4674ea3ada4bfc4811803c4')
+sha512sums=('f961bf8d5c9391959dcb8615963937b824f11586de7c66306b4654e444ef28cb389966582b9daffb356747c58cae057964a7641204f58f3c6b2ede3af1deb1c3')
+b2sums=('66fde40cb2f54954f2ca279c9dbedee1eb9942728ade58ea2943f698565b705cacd825e7002b3226d84deac5cf6a8ced1a54999fb1c6e24c2b9664053c1b2cf0')
build() {
cd "$_pkgname-$pkgver"
- poetry build --format wheel
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {