summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Catini2015-06-22 11:04:49 +0200
committerRoberto Catini2015-06-22 11:04:49 +0200
commitdacf1cfc3495cf715a94c0e9744cf6206cfddd8c (patch)
tree8aa6051a1c63f3b8f226748bc1ae39f806c8863e
downloadaur-dacf1cfc3495cf715a94c0e9744cf6206cfddd8c.tar.gz
Package created
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e24d70bf6267
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-turbogears
+ pkgdesc = A hybrid web framework able to act both as a Full Stack framework or as a Microframework
+ pkgver = 2.3.5
+ pkgrel = 1
+ url = http://www.turbogears.org/
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-webob
+ depends = python-crank
+ depends = python-beaker
+ depends = python-repoze.lru
+ source = git://github.com/TurboGears/tg2.git#tag=tg2.3.5
+ md5sums = SKIP
+
+pkgname = python-turbogears
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fac5542ac7ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Roberto Catini <roberto.catini@gmail.com>
+pkgname=python-turbogears
+pkgver=2.3.5
+pkgrel=1
+pkgdesc="A hybrid web framework able to act both as a Full Stack framework or as a Microframework"
+arch=('any')
+url="http://www.turbogears.org/"
+license=('MIT')
+depends=('python' 'python-webob' 'python-crank' 'python-beaker' 'python-repoze.lru')
+source=("git://github.com/TurboGears/tg2.git#tag=tg$pkgver")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/tg2"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}