summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2022-02-07 00:57:18 +1100
committerVictor Tran2022-02-07 00:57:18 +1100
commitdadcd26e04262a7f4792d511562bde37a5272705 (patch)
tree862ae5501a5ad27a42a10c883272cf61ae00de18
parent15768cccbe334098ed39d942e9fc8f5e9392988f (diff)
downloadaur-dadcd26e04262a7f4792d511562bde37a5272705.tar.gz
Update to 4.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 24 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f24b54f0ba27..b2cdc9db3c43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = thefile
- pkgdesc = Simple File Manager
- pkgver = 3.1
+ pkgdesc = File Manager
+ pkgver = 4.0
pkgrel = 0
url = https://github.com/vicr123/thefile
arch = x86_64
- license = GPL2
- makedepends = git
- makedepends = clang
- depends = kwidgetsaddons
+ license = GPL3
+ makedepends = qt5-tools
depends = xdg-utils
depends = qt5-base
- optdepends = jmtpfs: for MTP support
- optdepends = ifuse: for iOS support
- optdepends = usbmuxd: for iOS support
- optdepends = libplist: for iOS support
- source = thefile-3.1::git+https://github.com/vicr123/thefile#branch=master
- md5sums = SKIP
+ depends = the-libs
+ depends = libtdesktopenvironment
+ depends = libthefrisbee
+ depends = qt5-svg
+ source = thefile-4.0::https://github.com/vicr123/thefile/archive/refs/tags/v4.0.tar.gz
+ sha256sums = 214f4751b8d194adaa25f06176849242ade9539352672655cdf5071d240b17fa
pkgname = thefile
-
diff --git a/PKGBUILD b/PKGBUILD
index 2d28ae33cd0f..22bd2f41c5ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
-
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=thefile
-pkgver=3.1
+pkgver=4.0
pkgrel=0
-pkgdesc="Simple File Manager"
+pkgdesc="File Manager"
arch=("x86_64")
url="https://github.com/vicr123/thefile"
-license=('GPL2')
-depends=('kwidgetsaddons' 'xdg-utils' 'qt5-base')
-makedepends=('git' 'clang')
-optdepends=('jmtpfs: for MTP support'
- 'ifuse: for iOS support'
- 'usbmuxd: for iOS support'
- 'libplist: for iOS support')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/thefile#branch=master')
-md5sums=('SKIP')
+license=('GPL3')
+depends=('xdg-utils' 'qt5-base' 'the-libs' 'libtdesktopenvironment' 'libthefrisbee' 'qt5-svg')
+makedepends=('qt5-tools')
+source=("$pkgname-$pkgver"::"https://github.com/vicr123/thefile/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('214f4751b8d194adaa25f06176849242ade9539352672655cdf5071d240b17fa')
build() {
- cd "$pkgname-$pkgver"
- qmake
+ cd "thefile-$pkgver"
+ mkdir -p build
+ cd build
+ qmake ../theFile.pro
make
}
package() {
- mkdir -p "$pkgdir/usr/bin"
- cp "$pkgname-$pkgver/thefile" "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/applications"
- cp "$pkgname-$pkgver/theFile.desktop" "$pkgdir/usr/share/applications"
+ cd "thefile-$pkgver"
+ cd build
+ make install INSTALL_ROOT=$pkgdir
}