summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-01-13 20:00:51 +0100
committerMartchus2016-01-13 20:00:51 +0100
commitdade134079685653f1eebf5e3d61675e7f16168f (patch)
treefaf9a9bc55767d0ffeea061689498d8c3176bbf6
downloadaur-dade134079685653f1eebf5e3d61675e7f16168f.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..704899e51b17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 19:00:33 UTC 2016
+pkgbase = mingw-w64-libfilezilla-svn
+ pkgdesc = Library used by FileZilla (mingw-w64, svn version)
+ pkgver = r7253
+ pkgrel = 1
+ url = https://filezilla-project.org/
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-configure
+ makedepends = subversion
+ depends = mingw-w64-crt
+ provides = mingw-w64-libfilezilla
+ conflicts = mingw-w64-libfilezilla
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = libfilezilla::svn+https://svn.filezilla-project.org/svn/libfilezilla/trunk
+ md5sums = SKIP
+
+pkgname = mingw-w64-libfilezilla-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c0fe6fc6de3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+_name=libfilezilla
+pkgname=mingw-w64-libfilezilla-svn
+pkgver=r7253
+pkgrel=1
+pkgdesc="Library used by FileZilla (mingw-w64, svn version)"
+arch=('any')
+url="https://filezilla-project.org/"
+license=('GPL')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc' 'mingw-w64-configure' 'subversion')
+provides=(${pkgname%-svn})
+conflicts=(${pkgname%-svn})
+options=(staticlibs !strip !buildflags)
+install=
+source=("${_name}::svn+https://svn.filezilla-project.org/svn/libfilezilla/trunk")
+md5sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+prepare() {
+ cd "${srcdir}/${_name}"
+ autoreconf -i
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/${_name}/build-${_arch}" && cd "${srcdir}/${_name}/build-${_arch}"
+ ${_arch}-configure
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_name}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
+}