summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2021-06-23 09:52:27 -0400
committerAndrew O'Neill2021-06-23 09:52:27 -0400
commitdb171cbfcf226ef2454afd06fc6a6e412ea3159d (patch)
tree2e18a15f9cc8df474f11ef07037fcad33258c3ea
parentff450d572c06a6dcec4a8d82aec630fceb42ec32 (diff)
downloadaur-db171cbfcf226ef2454afd06fc6a6e412ea3159d.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--oci-cli.patch16
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e481b1af670..1e23319520e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 2.25.3
+ pkgver = 2.25.4
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,9 +22,9 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-2.25.3.tar.gz::https://github.com/oracle/oci-cli/archive/v2.25.3.tar.gz
+ source = oci-cli-2.25.4.tar.gz::https://github.com/oracle/oci-cli/archive/v2.25.4.tar.gz
source = oci-cli.patch
- sha256sums = 882566e1ef23bf029af9e5eefb16f79fe656ba299dbe90abda72a3c1cff2ca47
- sha256sums = c7a4a42c04ce39875f248d9317482b79130cdd943ea890f2e79a3738458b58a8
+ sha256sums = e0c3863528938ea856404fab217861de953b181b5db00cc69dab15e9f163c2c8
+ sha256sums = c3b4ea1b42c1f047d0c3b8a60dbb2627a6c4eada97dc607f3d7ba259924f53cd
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index 10a093bc6a35..220ab1c5799b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=2.25.3
+pkgver=2.25.4
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -12,8 +12,8 @@ makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
-sha256sums=('882566e1ef23bf029af9e5eefb16f79fe656ba299dbe90abda72a3c1cff2ca47'
- 'c7a4a42c04ce39875f248d9317482b79130cdd943ea890f2e79a3738458b58a8')
+sha256sums=('e0c3863528938ea856404fab217861de953b181b5db00cc69dab15e9f163c2c8'
+ 'c3b4ea1b42c1f047d0c3b8a60dbb2627a6c4eada97dc607f3d7ba259924f53cd')
prepare() {
cd "${pkgname}-${pkgver}"
diff --git a/oci-cli.patch b/oci-cli.patch
index de60e0a49d83..04cc0c424655 100644
--- a/oci-cli.patch
+++ b/oci-cli.patch
@@ -1,18 +1,18 @@
-diff -rupN oci-cli-2.25.3/setup.py oci-cli-2.25.3b/setup.py
---- oci-cli-2.25.3/setup.py 2021-06-15 17:24:27.000000000 -0400
-+++ oci-cli-2.25.3b/setup.py 2021-06-18 10:13:37.446161147 -0400
+diff -rupN oci-cli-2.25.4/setup.py oci-cli-2.25.4b/setup.py
+--- oci-cli-2.25.4/setup.py 2021-06-22 17:53:53.000000000 -0400
++++ oci-cli-2.25.4b/setup.py 2021-06-23 09:48:40.333834586 -0400
@@ -30,24 +30,23 @@ with open_relative("README.rst") as f:
readme = f.read()
requires = [
-- 'oci==2.40.0',
+- 'oci==2.40.1',
- 'arrow==0.17.0',
+ 'oci',
+ 'arrow',
'certifi',
- 'click==6.7',
- 'configparser==4.0.2',
-- 'cryptography==3.3.2',
+- 'cryptography>=3.2.1,<=3.4.7',
- 'jmespath==0.10.0',
- 'python-dateutil>=2.5.3,<3.0.0',
- 'pytz>=2016.10',
@@ -39,9 +39,9 @@ diff -rupN oci-cli-2.25.3/setup.py oci-cli-2.25.3b/setup.py
}
fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-diff -rupN oci-cli-2.25.3/src/oci_cli/cli_root.py oci-cli-2.25.3b/src/oci_cli/cli_root.py
---- oci-cli-2.25.3/src/oci_cli/cli_root.py 2021-06-15 17:24:27.000000000 -0400
-+++ oci-cli-2.25.3b/src/oci_cli/cli_root.py 2021-06-18 10:13:58.236343058 -0400
+diff -rupN oci-cli-2.25.4/src/oci_cli/cli_root.py oci-cli-2.25.4b/src/oci_cli/cli_root.py
+--- oci-cli-2.25.4/src/oci_cli/cli_root.py 2021-06-22 17:53:53.000000000 -0400
++++ oci-cli-2.25.4b/src/oci_cli/cli_root.py 2021-06-23 09:49:04.303835598 -0400
@@ -307,7 +307,7 @@ For information on configuration, see ht
@click.option('--profile',
default=Sentinel(DEFAULT_PROFILE), show_default=False,