summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavel Ruzicka2022-05-11 10:22:48 +0200
committerPavel Ruzicka2022-05-11 10:22:48 +0200
commitdb730fc35a03aeb85343b1e0e7b41f06056d97db (patch)
tree1daf2017d34ae555d614b059457b396601c74d06
parentbf16217b7e3969dfab7be4aedc88b60e46216d2e (diff)
downloadaur-db730fc35a03aeb85343b1e0e7b41f06056d97db.tar.gz
Update to 2.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--geographiclib.install4
3 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79da22a2e5a8..0c2dcb28b2f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = geographiclib
pkgdesc = Set of C++ classes for conversions between geographic, UTM, UPS, MGRS, geocentric, and local cartesian coordinates, for gravity, geoid height, and geomagnetic field calculations and for solving geodesic problems. Geotrans replacement.
- pkgver = 1.52
+ pkgver = 2.0
pkgrel = 1
- url = http://geographiclib.sourceforge.io/
+ url = https://geographiclib.sourceforge.io/
install = geographiclib.install
arch = i686
arch = x86_64
- license = custom
+ license = MIT
makedepends = gcc
makedepends = make
makedepends = cmake
depends = bash
options = staticlibs
- source = http://downloads.sourceforge.net/project/geographiclib/distrib/GeographicLib-1.52.tar.gz
- md5sums = 52407e8380335957377c6ac6118ce6e3
+ source = https://sourceforge.net/projects/geographiclib/files/distrib-C%2B%2B/GeographicLib-2.0.tar.gz/download
+ md5sums = dafd8c995758f3b9205702a8019e6ca3
pkgname = geographiclib
diff --git a/PKGBUILD b/PKGBUILD
index 4da510410d2f..6c4e82c5c18d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=geographiclib
_pkgname=GeographicLib
-pkgver=1.52
+pkgver=2.0
pkgrel=1
pkgdesc="Set of C++ classes for conversions between geographic, UTM, UPS, MGRS, geocentric, and local cartesian coordinates, for gravity, geoid height, and geomagnetic field calculations and for solving geodesic problems. Geotrans replacement."
arch=('i686' 'x86_64')
-url="http://geographiclib.sourceforge.io/"
-license=('custom') # MIT/X11
+url="https://geographiclib.sourceforge.io/"
+license=('MIT')
depends=('bash')
makedepends=('gcc' 'make' 'cmake')
options=('staticlibs')
-source=(http://downloads.sourceforge.net/project/geographiclib/distrib/${_pkgname}-${pkgver}.tar.gz)
-md5sums=('52407e8380335957377c6ac6118ce6e3')
+source=(https://sourceforge.net/projects/geographiclib/files/distrib-C%2B%2B/${_pkgname}-${pkgver}.tar.gz/download)
+md5sums=('dafd8c995758f3b9205702a8019e6ca3')
install=geographiclib.install
@@ -22,7 +22,7 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
cmake ./ \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DGEOGRAPHICLIB_LIB_TYPE=BOTH
+ -DBUILD_BOTH_LIBS=ON
make
}
diff --git a/geographiclib.install b/geographiclib.install
index e8fe7cd79607..74526b8553d2 100644
--- a/geographiclib.install
+++ b/geographiclib.install
@@ -6,9 +6,7 @@ _info() {
echo " geographiclib-get-gravity"
echo " geographiclib-get-magnetic"
echo "For details see:"
- echo " https://geographiclib.sourceforge.io/html/geoid.html"
- echo " https://geographiclib.sourceforge.io/html/gravity.html"
- echo " https://geographiclib.sourceforge.io/html/magnetic.html"
+ echo " https://geographiclib.sourceforge.io/doc/library.html#datasets"
echo "----------------------------------------------------------"
}