summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-14 12:53:23 -0700
committeryochananmarqos2019-12-14 12:53:23 -0700
commitdb9dd02a9817ea450b7f79580b23bf112176146a (patch)
treef0e2c9e6903071e298310a06e2a91a25c4bc64f1
parent74653ddcfaae6ef088c8301c7a69ea85201016f1 (diff)
downloadaur-db9dd02a9817ea450b7f79580b23bf112176146a.tar.gz
install SVG in proper place
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ba4e6f3ebc1..2d7917d6c65f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kindd
- pkgdesc = A Kindful dd gui written in qt quick
+ pkgdesc = A Kindful dd GUI written in Qt Quick
pkgver = 2.0.1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/LinArcX/Kindd
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 415ee582c279..a3b31e3d3645 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: LinArcx <linarcx at gmail.com>
pkgname=kindd
pkgver=2.0.1
-pkgrel=5
-pkgdesc=" A Kindful dd gui written in qt quick"
+pkgrel=6
+pkgdesc="A Kindful dd GUI written in Qt Quick"
arch=('any')
url="https://github.com/LinArcX/Kindd"
license=('GPL3')
-depends=('polkit' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-graphicaleffects' 'qt5-svg')
+depends=('polkit' 'qt5-quickcontrols' 'qt5-quickcontrols2'
+ 'qt5-graphicaleffects' 'qt5-svg')
conflicts=("$pkgname-git")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/LinArcX/Kindd/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('5dbfcbc07cdc36a6a5d2b40ed5e8159a305ccc5608580635961ed9ad6f43e2b3')
build() {
@@ -20,9 +21,10 @@ build() {
package() {
cd "Kindd-$pkgver"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 appconf/"$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 appconf/"$pkgname.svg" "$pkgdir/usr/share/pixmaps/kindd.svg"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 appconf/"$pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 appconf/"$pkgname.svg" -t \
+ "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}