summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2023-01-15 13:18:36 +0200
committerPhilipp Joram2023-01-15 13:33:57 +0200
commitdbdf54d87379b2687b67512eb99b45af7473cdf5 (patch)
tree7b433e049585f7f305fb0ab7189731811c68c784
parentaedb91f4109f9edd54d19e025c5d60cef29b73b1 (diff)
downloadaur-dbdf54d87379b2687b67512eb99b45af7473cdf5.tar.gz
Be generic over PyPI package name
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3911eb3b54ca..449fc87fa8f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
# Contributor: evertonstz <evertonjcorreia@gmail.com>
# Contributor: phijor <mail [at] phijor [dot] me>
-_pkgname=iris
-pkgname=mopidy-${_pkgname}
+_name=Mopidy-Iris
+pkgname=mopidy-iris
pkgver=3.65.0
pkgrel=1
pkgdesc='A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)'
arch=('any')
-url="https://github.com/jaedb/${_pkgname}"
+url="https://github.com/jaedb/iris"
license=('APACHE')
depends=('mopidy>=3' 'python-configobj' 'python-pylast')
makedepends=('python-setuptools' 'python-pip')
optdepends=('mopidy-local: local library support'
'mopidy-spotify: spotify support')
-source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/M/Mopidy-Iris/Mopidy-Iris-${pkgver}.tar.gz")
+source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('800ebe9e922d8c6d632080d2d4cbdade39d18ceb8eeda5fd4328facf7d52ab42')
package() {
- cd "${srcdir}/Mopidy-Iris-${pkgver}"
+ cd "${_name}-$pkgver"
python setup.py install --root="${pkgdir}/" --optimize=1
}