summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeinzi2019-07-22 01:57:59 +0200
committerJeinzi2019-07-22 01:57:59 +0200
commitdbfd544c743692fd2cfd6afc4817ca07178f3688 (patch)
tree7c34a543e3455d659b3a999ad9ec98e07ade2326
parent32e80e5dfeadadaa902bc7f5850901567b7d0843 (diff)
downloadaur-dbfd544c743692fd2cfd6afc4817ca07178f3688.tar.gz
Removed unnecessary dependencies, improved install().
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9334dfd79724..311341b034cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Handy scripts for i3 window manager: smart resize/open new workspace."
arch=('any')
url="https://github.com/vivien/helpers-for-i3.git"
license=('GPL3')
-depends=('i3-wm' 'python' 'python-i3ipc')
+depends=('i3-wm' 'python-i3ipc')
makedepends=('git')
source=("$pkgname::git+https://github.com/vivien/helpers-for-i3#branch=master")
sha256sums=('SKIP')
@@ -18,7 +18,5 @@ pkgver() {
}
package() {
- mkdir -p "$pkgdir/usr/bin/"
- cp -v "$srcdir/$pkgname/"{i3-new-workspace,i3-smart-resize} "$pkgdir/usr/bin/"
- chmod 755 "$pkgdir/usr/bin/"{i3-new-workspace,i3-smart-resize}
+ install -Dv -t "$pkgdir/usr/bin/" "$srcdir/$pkgname/"{i3-new-workspace,i3-smart-resize}
}