summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorahmedmoselhi2023-01-30 00:32:55 +0200
committerahmedmoselhi2023-01-30 00:32:55 +0200
commitdbfe29c8202ae00f3c989a01d459cedf19947139 (patch)
tree9ada0c082c59c13dfcd4ef13607a5045a945869a
parent076fc97bae4c5cf9008aec2eb29ed8039910c794 (diff)
downloadaur-dbfe29c8202ae00f3c989a01d459cedf19947139.tar.gz
update to version 2.4
add various patches
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--acetoneiso-2.4-deb-add_manpage.patch64
-rw-r--r--acetoneiso-2.4-deb-remove_defunct_homepage.patch91
-rw-r--r--acetoneiso-2.4-mga-youtube-metacafe.patch20
5 files changed, 208 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1501e226e840..fe7d1adc5fb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = acetoneiso2
pkgdesc = An all in one ISO tool (bin mdf nrg img daa dmg cdi b5i bwi pdi iso)
- pkgver = 2.3
- pkgrel = 12
+ pkgver = 2.4
+ pkgrel = 1
url = https://sourceforge.net/projects/acetoneiso
install = acetoneiso2.install
arch = x86_64
@@ -15,10 +15,16 @@ pkgbase = acetoneiso2
depends = mplayer
depends = phonon-qt5
depends = qt5-webkit
+ depends = md4c
optdepends = p7zip: for ISO compress/decompress support
conflicts = acetoneiso
- source = https://downloads.sourceforge.net/acetoneiso/AcetoneISO/AcetoneISO%202.3/acetoneiso_2.3.tar.gz
- md5sums = 225f7af687016690ff28b9771a1ce179
- sha256sums = ea1e6f285d23f08892ceb9ec336040b33b199fedf42881ef1374ca9f279a0768
+ source = acetoneiso-2.4.tar.gz::http://deb.debian.org/debian/pool/main/a/acetoneiso/acetoneiso_2.4.orig.tar.gz
+ source = acetoneiso-2.4-deb-add_manpage.patch
+ source = acetoneiso-2.4-mga-youtube-metacafe.patch
+ source = acetoneiso-2.4-deb-remove_defunct_homepage.patch
+ sha256sums = 5ac6038fad5ebdd9832aed1a9d88e5fbc6dabf648de16324c4e303c564f23ba0
+ sha256sums = 33cb44e86f32b5a78e226e5bcc53ffa2349c499321c627b273e35bcefd8663ee
+ sha256sums = dd56ea08177d69596a8451c62e448594d66c8d2d6313072bf71cb8fcd013b690
+ sha256sums = 715f8dc331ced1f17501e6489202237e4bcb7df760a9b2a3c2aa02bce6564f36
pkgname = acetoneiso2
diff --git a/PKGBUILD b/PKGBUILD
index b93214af1533..9a7a25a21cef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,31 @@
# Contributor: Wes Brewer <brewerw@gmail.com>
pkgname=acetoneiso2
-pkgver=2.3
-pkgrel=12
+_pkgname=acetoneiso
+pkgver=2.4
+pkgrel=1
pkgdesc="An all in one ISO tool (bin mdf nrg img daa dmg cdi b5i bwi pdi iso)"
arch=('x86_64')
url="https://sourceforge.net/projects/acetoneiso"
license=('GPL3')
-depends=('fuseiso' 'cdrdao' 'cdrtools' 'dvd+rw-tools' 'gnupg' 'pinentry' 'mplayer' 'phonon-qt5' 'qt5-webkit')
+depends=('fuseiso' 'cdrdao' 'cdrtools' 'dvd+rw-tools' 'gnupg' 'pinentry' 'mplayer' 'phonon-qt5' 'qt5-webkit' 'md4c')
optdepends=("p7zip: for ISO compress/decompress support")
conflicts=('acetoneiso')
install=${pkgname}.install
-source=(https://downloads.sourceforge.net/acetoneiso/AcetoneISO/AcetoneISO%202.3/acetoneiso_${pkgver}.tar.gz)
-md5sums=('225f7af687016690ff28b9771a1ce179')
-sha256sums=('ea1e6f285d23f08892ceb9ec336040b33b199fedf42881ef1374ca9f279a0768')
+source=("${_pkgname}-${pkgver}.tar.gz::http://deb.debian.org/debian/pool/main/a/${_pkgname}/${_pkgname}_${pkgver}.orig.tar.gz"
+ 'acetoneiso-2.4-deb-add_manpage.patch'
+ 'acetoneiso-2.4-mga-youtube-metacafe.patch'
+ 'acetoneiso-2.4-deb-remove_defunct_homepage.patch')
+sha256sums=('5ac6038fad5ebdd9832aed1a9d88e5fbc6dabf648de16324c4e303c564f23ba0'
+ '33cb44e86f32b5a78e226e5bcc53ffa2349c499321c627b273e35bcefd8663ee'
+ 'dd56ea08177d69596a8451c62e448594d66c8d2d6313072bf71cb8fcd013b690'
+ '715f8dc331ced1f17501e6489202237e4bcb7df760a9b2a3c2aa02bce6564f36')
prepare() {
- cd acetoneiso_${pkgver}/acetoneiso
-
+
+ rm -rf ${_pkgname}${pkgver}/${_pkgname}
+ tar -xzf ${_pkgname}-${pkgver}.tar.gz
+ cd ${_pkgname}${pkgver}/${_pkgname}
sed -i 's#<Phonon/#<phonon/#' sources/*
# Port to Qt5 https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1563802.html
sed -i 's/QtGui/QtWidgets/' sources/*
@@ -32,17 +40,21 @@ prepare() {
# Remove malware from loading in the Updates tab, due to an expired domain being captured.
sed -i 's#http://www.acetoneteam.org/clients.html##' ui/acetoneiso.ui
+ # apply patches
+ patch -Np1 -i ../../acetoneiso-2.4-deb-add_manpage.patch
+ patch -Np1 -i ../../acetoneiso-2.4-mga-youtube-metacafe.patch
+ patch -Np1 -i ../../acetoneiso-2.4-deb-remove_defunct_homepage.patch
}
build() {
- cd acetoneiso_${pkgver}/acetoneiso
+ cd ${_pkgname}${pkgver}/${_pkgname}
qmake-qt5
make
}
package() {
- cd acetoneiso_${pkgver}/acetoneiso
+ cd ${_pkgname}${pkgver}/${_pkgname}
make INSTALL_ROOT="${pkgdir}" install
}
diff --git a/acetoneiso-2.4-deb-add_manpage.patch b/acetoneiso-2.4-deb-add_manpage.patch
new file mode 100644
index 000000000000..bef52808f676
--- /dev/null
+++ b/acetoneiso-2.4-deb-add_manpage.patch
@@ -0,0 +1,64 @@
+Include a manpage for the command line usage of the program.
+
+Author: Nick Andrik <nick.andrik@gmail.com>
+
+--- /dev/null 2023-01-29 19:33:21.505227020 +0200
++++ acetoneiso/manual/acetoneiso.1 2023-01-29 23:10:55.994370468 +0200
+@@ -0,0 +1,56 @@
++.\" Hey, EMACS: -*- nroff -*-
++.\" First parameter, NAME, should be all caps
++.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
++.\" other parameters are allowed: see man(7), man(1)
++.TH ACETONEISO 1 "November 15, 2010" "AcetoneISO 2.3"
++.\" Please adjust this date whenever revising the manpage.
++.\"
++.\" Some roff macros, for reference:
++.\" .nh disable hyphenation
++.\" .hy enable hyphenation
++.\" .ad l left justify
++.\" .ad b justify to both left and right margins
++.\" .nf disable filling
++.\" .fi enable filling
++.\" .br insert line break
++.\" .sp <n> insert n+1 empty lines
++.\" for manpage-specific macros, see man(7)
++.SH NAME
++acetoneiso \- feature-rich graphical application to mount and manage CD/DVD images
++
++.SH SYNOPSIS
++.B acetoneiso
++.RI "[OPTION] [FILE]"
++.br
++
++.SH DESCRIPTION
++Opens a graphical filemanager which lets you mount typical proprietary images
++formats of the Windows world such as ISO BIN NRG MDF IMG and do plenty of other things.
++.PP
++If
++.RI FILE
++is specified, then the program mounts the image before opening the GUI.
++.PP
++.\" TeX users may be more comfortable with the \fB<whatever>\fP and
++.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
++.\" respectively.
++
++.SH OPTIONS
++.TP
++.B \-\-help
++.br
++Print a help message and exit.
++
++.SH SEE ALSO
++A detailed manual for
++.B acetoneiso
++can be found from the menu of the graphical filemanger in Help -> Manual.
++
++\fIhttp://www.acetoneteam.org/\fR
++
++.SH AUTHOR
++.B acetoneiso
++was written by Fabrizio Di Marco and Marco Di Antonio <acetoneiso@gmail.com>.
++.PP
++This manual page was written by Nick Andrik <nick.andrik@gmail.com>,
++for the Debian project (and may be used by others).
+\ No newline at end of file \ No newline at end of file
diff --git a/acetoneiso-2.4-deb-remove_defunct_homepage.patch b/acetoneiso-2.4-deb-remove_defunct_homepage.patch
new file mode 100644
index 000000000000..5e7573b72016
--- /dev/null
+++ b/acetoneiso-2.4-deb-remove_defunct_homepage.patch
@@ -0,0 +1,91 @@
+Remove references to defunct acetoneteam.org homepage.
+The web site has expired and others have acquired the domain.
+
+Author: Nick Andrik <nick.andrik@gmail.com>
+
+--- acetoneiso/sources/connections.h
++++ acetoneiso/sources/connections.h
+@@ -23,7 +23,7 @@
+
+ connect( pushButton_6, SIGNAL( clicked() ), this, SLOT( hide_process_display() ) );
+
+- connect(actionMake_a_small_donation, SIGNAL( triggered() ), this, SLOT( paypal() ) );
++ //connect(actionMake_a_small_donation, SIGNAL( triggered() ), this, SLOT( paypal() ) );
+ connect( pushButton_4, SIGNAL( triggered() ), this, SLOT( extract() ) );
+
+ connect( actionSha1_check, SIGNAL( triggered() ), this, SLOT( sha1() ) );
+@@ -31,7 +31,7 @@
+ connect( actionSha512_check, SIGNAL( triggered() ), this, SLOT( sha384() ) );
+
+ connect( actionMount_Image, SIGNAL( triggered() ), this, SLOT( mount() ) );
+- connect( actionDonate, SIGNAL( triggered() ), this, SLOT( a_donate() ) );
++ //connect( actionDonate, SIGNAL( triggered() ), this, SLOT( a_donate() ) );
+ connect( actionExit, SIGNAL( triggered() ), qApp, SLOT( quit() ) );
+ connect( pushButton_Omni_3, SIGNAL( triggered() ), this, SLOT( converter() ) );
+ connect( pushButton_IsoFromFolder_2, SIGNAL( triggered() ), this, SLOT( foldertoiso() ) );
+
+--- acetoneiso/sources/main.cpp
++++ acetoneiso/sources/main.cpp
+@@ -24,7 +24,7 @@
+ //const char *h = "--help";
+ QString clImage = argv[1];
+ if ( clImage.contains("--help") or clImage.contains("-h")) {
+- printf ( "\nAcetoneISO Distribuited under GPL v.3.0 \nAuthors:\nMarco Di Antonio 2010\nFabrizio Di Marco and Marco Di Antonio 2006-2007-2008-2009 \nContact: acetoneiso@gmail.com\nWebsite:www.acetoneteam.org\nusage: \nacetoneiso [$path_to_imagefile_to_mount] --> mounts given image and opens it in default filemanager \nacetoneiso --> opens AcetoneISO GUI\nacetoneiso --help --> shows this help\n\n" );
++ printf ( "\nAcetoneISO Distribuited under GPL v.3.0 \nAuthors:\nMarco Di Antonio 2010\nFabrizio Di Marco and Marco Di Antonio 2006-2007-2008-2009 \nContact: acetoneiso@gmail.com\nusage: \nacetoneiso [$path_to_imagefile_to_mount] --> mounts given image and opens it in default filemanager \nacetoneiso --> opens AcetoneISO GUI\nacetoneiso --help --> shows this help\n\n" );
+ }
+ else {
+ //printf ( "Mounting %s\n", argv[1] );
+
+--- acetoneiso/manual/acetoneiso.1
++++ acetoneiso/manual/acetoneiso.1
+@@ -46,8 +46,6 @@
+ .B acetoneiso
+ can be found from the menu of the graphical filemanger in Help -> Manual.
+
+-\fIhttp://www.acetoneteam.org/\fR
+-
+ .SH AUTHOR
+ .B acetoneiso
+ was written by Fabrizio Di Marco and Marco Di Antonio <acetoneiso@gmail.com>.
+
+--- acetoneiso/sources/messages.h
++++ acetoneiso/sources/messages.h
+@@ -171,7 +171,7 @@
+ int valore_uscita = FUse.exitCode();
+ if(!valore_uscita == 0){
+ status_mounted_no_boot();
+- QMessageBox::critical (this, "AcetoneISO",tr("Error, could not mount image.\n\nSolution:\nTry converting the image to ISO or extract the content to a folder from the upper menu \"Image Conversion.\"\nNOTE: it is NOT possible to mount multi-sector images.\nFor more information, please visit official website: http://www.acetoneteam.org" ));
++ QMessageBox::critical (this, "AcetoneISO",tr("Error, could not mount image.\n\nSolution:\nTry converting the image to ISO or extract the content to a folder from the upper menu \"Image Conversion.\"\nNOTE: it is NOT possible to mount multi-sector images." ));
+ }
+ else{
+ status_mounted_no_boot();
+
+--- acetoneiso/ui/acetoneiso.ui
++++ acetoneiso/ui/acetoneiso.ui
+@@ -695,7 +695,7 @@
+ </item>
+ </layout>
+ </widget>
+- <widget class="QWidget" name="tab_2">
++ <!--widget class="QWidget" name="tab_2">
+ <attribute name="icon">
+ <iconset resource="../acetoneiso.qrc">
+ <normaloff>:/images/splash.png</normaloff>:/images/splash.png</iconset>
+@@ -738,7 +738,7 @@
+ </widget>
+ </item>
+ </layout>
+- </widget>
++ </widget-->
+ </widget>
+ </item>
+ <item row="1" column="0">
+@@ -921,7 +921,7 @@
+ </property>
+ <addaction name="separator"/>
+ <addaction name="actionManual"/>
+- <addaction name="actionMake_a_small_donation"/>
++ <!--addaction name="actionMake_a_small_donation"/-->
+ <addaction name="actionAbout"/>
+ </widget>
+ <widget class="QMenu" name="menuConversion"> \ No newline at end of file
diff --git a/acetoneiso-2.4-mga-youtube-metacafe.patch b/acetoneiso-2.4-mga-youtube-metacafe.patch
new file mode 100644
index 000000000000..943938ba0682
--- /dev/null
+++ b/acetoneiso-2.4-mga-youtube-metacafe.patch
@@ -0,0 +1,20 @@
+--- acetoneiso/sources/utube.h 2016-02-24 20:44:40.000000000 +0300
++++ acetoneiso/sources/utube.h 2016-02-24 20:59:42.000000000 +0300
+@@ -18,7 +18,7 @@
+ QFile yutubbodl(Homeutube.path() + "/.acetoneiso/youtube-dl");
+ yutubbodl.remove();
+ //system ("rm $HOME/.acetoneiso/youtube-dl > /dev/null 2>&1");
+-if (system ("cd $HOME/.acetoneiso/;wget http://digilander.libero.it/bulletxt/youtube-dl > /dev/null 2>&1" ) ) {
++if (system ("cd $HOME/.acetoneiso/;wget https://yt-dl.org/downloads/latest/youtube-dl > /dev/null 2>&1" ) ) {
+
+ }
+ //system ("chmod 755 $HOME/.acetoneiso/youtube-dl > /dev/null 2>&1");
+@@ -149,7 +149,7 @@
+ QFile yutubbodl(Homeutube.path() + "/.acetoneiso/metacafe-dl");
+ yutubbodl.remove();
+ //system ("rm $HOME/.acetoneiso/metacafe-dl > /dev/null 2>&1");
+-if (system ("cd $HOME/.acetoneiso/;wget http://www.arrakis.es/~rggi3/metacafe-dl/metacafe-dl > /dev/null 2>&1")) {
++if (system ("cd $HOME/.acetoneiso/;wget https://raw.githubusercontent.com/glixx/metacafe-dl/master/metacafe-dl > /dev/null 2>&1")) {
+ }
+ //system ("chmod 755 $HOME/.acetoneiso/metacafe-dl > /dev/null 2>&1");
+ yutubbodl.setPermissions(QFile::ReadOwner | QFile::WriteOwner | QFile::ExeOwner | QFile::ExeGroup | QFile::ReadGroup | QFile::ReadOther | QFile::ExeOther); \ No newline at end of file