summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-02 14:33:53 +1300
committercaltlgin2020-11-02 14:33:53 +1300
commitdc1cab947fcd66c1c7bde07d34fc1960a8be5c82 (patch)
treeed5892489941b87a5e7c6a5dac92f066cef94c86
parentc203e093e6ddb22e6afdb6cb95a55589d9c4c2d5 (diff)
downloadaur-dc1cab947fcd66c1c7bde07d34fc1960a8be5c82.tar.gz
Add -qt4 suffix to lupdate and lrelease commands
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--unetbootin.sh11
3 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85280f6ccffd..76c07760c48c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unetbootin
pkgdesc = Create bootable Live USB drives
pkgver = 681
- pkgrel = 1
+ pkgrel = 2
url = https://unetbootin.github.io
arch = x86_64
license = GPL3
@@ -10,13 +10,12 @@ pkgbase = unetbootin
depends = p7zip
depends = qt4
depends = syslinux
- depends = zenity
optdepends = polkit: run unetbootin directly from menu
source = unetbootin-681::https://github.com/unetbootin/unetbootin/archive/681.tar.gz
source = unetbootin.sh
source = org.archlinux.pkexec.unetbootin.policy
sha256sums = ec62a6321c39203a096d6a778b2f1518da815ece135e5eb95ba1e42e28ec240a
- sha256sums = c3bfa4723c1834d608be97ecf7b0c6975f6d0f9af2358427e4c9aa2f6c58c2e3
+ sha256sums = 6b99405a78ac4de80e3a20e766ce993f22c8a01e4ab50f952a10bdcc26effd3f
sha256sums = 118f154e2772ff0d50d22735418fb37c9a03ecd0a1bbf2c8a4a8ed48da64160c
pkgname = unetbootin
diff --git a/PKGBUILD b/PKGBUILD
index af4079cc4fe6..ba944046fc34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,20 @@
pkgname='unetbootin'
pkgver=681
-pkgrel=1
+pkgrel=2
pkgdesc='Create bootable Live USB drives'
arch=('x86_64')
url='https://unetbootin.github.io'
_url_source='https://github.com/unetbootin/unetbootin'
license=('GPL3')
-depends=('mtools' 'p7zip' 'qt4' 'syslinux' 'zenity')
-#depends=('mtools' 'p7zip' 'qt5-base' 'syslinux' 'zenity') # qt5
+depends=('mtools' 'p7zip' 'qt4' 'syslinux')
makedepends=('setconf')
optdepends=('polkit: run unetbootin directly from menu')
source=("${pkgname}-${pkgver}::${_url_source}/archive/${pkgver}.tar.gz"
"${pkgname}.sh"
"org.archlinux.pkexec.${pkgname}.policy")
sha256sums=('ec62a6321c39203a096d6a778b2f1518da815ece135e5eb95ba1e42e28ec240a'
- 'c3bfa4723c1834d608be97ecf7b0c6975f6d0f9af2358427e4c9aa2f6c58c2e3'
+ '6b99405a78ac4de80e3a20e766ce993f22c8a01e4ab50f952a10bdcc26effd3f'
'118f154e2772ff0d50d22735418fb37c9a03ecd0a1bbf2c8a4a8ed48da64160c')
prepare() {
@@ -31,11 +30,10 @@ prepare() {
sed -i '/^RESOURCES/d' "${pkgname}.pro"
}
-# Update on qt5 release
build() {
cd "${pkgname}-${pkgver}/src/${pkgname}"
- lupdate "${pkgname}.pro"
- lrelease "${pkgname}.pro"
+ lupdate-qt4 "${pkgname}.pro"
+ lrelease-qt4 "${pkgname}.pro"
qmake-qt4 "${pkgname}.pro" -config release "DEFINES += NOSTATIC" "RESOURCES -= ${pkgname}.qrc"
make
}
diff --git a/unetbootin.sh b/unetbootin.sh
index 8296ed5aa8c9..4e85a7769f7b 100644
--- a/unetbootin.sh
+++ b/unetbootin.sh
@@ -2,15 +2,8 @@
export QT_X11_NO_MITSHM=1
-ELF_FILE='/usr/bin/unetbootin.elf'
-TMP_FILE='/tmp/_polkit_error'
-
if [ $(command -v pkexec) ]; then
- pkexec --disable-internal-agent "${ELF_FILE}" "$@" 2>"${TMP_FILE}"
- if [ -s "${TMP_FILE}" ]; then
- zenity --error --text="$(cat ${TMP_FILE})"
- rm -f "${TMP_FILE}"
- fi
+ pkexec --disable-internal-agent '/usr/bin/unetbootin.elf' "$@"
else
- "${ELF_FILE}" "$@"
+ '/usr/bin/unetbootin.elf' "$@"
fi