summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-01-21 14:00:33 -0300
committerDaniel Bermond2023-01-21 14:00:33 -0300
commitdc1d0f8d01b6eb05a23be0bfda22aa9be8e0e8cb (patch)
tree07288da7b844cd7cac56546be04a3b4f2088b252
parent4538735d9ecd2c1736bea840d21b799e3b5cdb29 (diff)
downloadaur-dc1d0f8d01b6eb05a23be0bfda22aa9be8e0e8cb.tar.gz
Update to version 4.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--010-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49c9973245a3..c6ab8ef89944 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 4.2.0
+ pkgver = 4.3.0
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.2.0
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.3.0
source = git+https://github.com/google/googletest.git
source = 010-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = de18c29f9a12f00562487e73d255135184bb74cd0ebacd0576363655e7071e55
+ sha256sums = 29a968ae8df5391320eb804d8f79af75a18219df3734cbb5bced67d82cc7a661
pkgname = astc-encoder
diff --git a/010-astc-encoder-use-shared-library.patch b/010-astc-encoder-use-shared-library.patch
index 89b87911ba69..03b9e32b0079 100644
--- a/010-astc-encoder-use-shared-library.patch
+++ b/010-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -302,16 +306,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -308,16 +312,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -64,7 +64,7 @@
PRIVATE
$<$<CXX_COMPILER_ID:MSVC>:/W3>)
-@@ -322,9 +326,10 @@ if(${CLI})
+@@ -328,9 +332,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index 96174a2c58f5..ec6e1e6a78d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=4.2.0
+pkgver=4.3.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -14,7 +14,7 @@ source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
'010-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- 'de18c29f9a12f00562487e73d255135184bb74cd0ebacd0576363655e7071e55')
+ '29a968ae8df5391320eb804d8f79af75a18219df3734cbb5bced67d82cc7a661')
prepare() {
git -C astc-encoder submodule init