summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBilal Elmoussaoui2017-01-13 16:18:50 +0100
committerBilal Elmoussaoui2017-01-13 16:18:50 +0100
commitdc6a82912b7b005da47cd9a1a5aacdc3ebd77711 (patch)
treec75107cad760d68d4da4451ba38fbb84123797b1
downloadaur-dc6a82912b7b005da47cd9a1a5aacdc3ebd77711.tar.gz
first archlinux release
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD51
-rw-r--r--ndm.desktop9
-rw-r--r--ndm128.pngbin0 -> 5002 bytes
-rw-r--r--ndm16.pngbin0 -> 441 bytes
-rw-r--r--ndm24.pngbin0 -> 839 bytes
-rw-r--r--ndm256.pngbin0 -> 12250 bytes
-rw-r--r--ndm32.pngbin0 -> 959 bytes
-rw-r--r--ndm48.pngbin0 -> 1710 bytes
-rw-r--r--ndm512.pngbin0 -> 34527 bytes
-rw-r--r--ndm64.pngbin0 -> 2259 bytes
-rw-r--r--ndm96.pngbin0 -> 3728 bytes
12 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..629fc52f0d3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = ndm
+ pkgdesc = npm desktop manager
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/720kb/ndm
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ provides = ndm
+ source = ndm.desktop
+ source = ndm16.png
+ source = ndm24.png
+ source = ndm32.png
+ source = ndm48.png
+ source = ndm64.png
+ source = ndm96.png
+ source = ndm128.png
+ source = ndm256.png
+ source = ndm512.png
+ sha256sums = c39a5951e9fe3c9156d3b01e03bdcce4717f9282a9879e8a0a1ad2b36605061e
+ sha256sums = c00b94fcd27bdf4a4749114a68c0f439704ea46ca72f131e366efcf6f721cc77
+ sha256sums = 320664a794faa12ac1977772c479fb2a3628cb15e37e5d9b04e7b0acd210935b
+ sha256sums = 51122b1be8b8bf839c48f981651a2e9ef1879d7d27fbf8f82d2ce3066907c110
+ sha256sums = 3f97a2e4ff971f747b3383e38b003557b24c68a072bd705068c2b7fbee4d851e
+ sha256sums = 6cd698e47c1e803fffc88db6c954708f9b5300fdb37cb6957aaf7845061815f8
+ sha256sums = 3afcbf1044f780f5cbbde0a0bd8ec8037547e3853544e80c3bd87836092910b2
+ sha256sums = d21b7bcb7aa615f0e0e7af21d8b209f448da928b47c75b61455069eadd3d738d
+ sha256sums = e43cc2bcc12f29cac03f667e480f059e5391c29d075ad7821f1411cea67ac1b1
+ sha256sums = dec92be5e28941f99a0c81c0cb1df8ec76abea6fed58481f412d4a92972bc40c
+ source_x86_64 = https://github.com/720kb/ndm/releases/download/v0.1.3/ndm-0.1.3.zip
+ sha256sums_x86_64 = 23676122af122dba27616716dd1e3d649dd83c96a80219f97398d2830547a5ee
+
+pkgname = ndm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18f4b076e2d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Bilal ELmoussaoui <bil.elmoussaoui@gmail.com>
+
+pkgname=ndm
+_pkgbase=ndm
+pkgrel=1
+pkgver=0.1.3
+_pkgver=v$pkgver
+pkgdesc="npm desktop manager"
+url="https://github.com/720kb/ndm"
+provides=('ndm')
+arch=('x86_64')
+license=('MIT')
+makedepends=('unzip')
+backup=()
+install=''
+source=(
+ "${_pkgbase}.desktop"
+ ${_pkgbase}{16,24,32,48,64,96,128,256,512}.png
+)
+
+source_x86_64+=("${url}/releases/download/${_pkgver}/${_pkgbase}-${pkgver}.zip")
+sha256sums=(
+ 'c39a5951e9fe3c9156d3b01e03bdcce4717f9282a9879e8a0a1ad2b36605061e'
+ 'c00b94fcd27bdf4a4749114a68c0f439704ea46ca72f131e366efcf6f721cc77'
+ '320664a794faa12ac1977772c479fb2a3628cb15e37e5d9b04e7b0acd210935b'
+ '51122b1be8b8bf839c48f981651a2e9ef1879d7d27fbf8f82d2ce3066907c110'
+ '3f97a2e4ff971f747b3383e38b003557b24c68a072bd705068c2b7fbee4d851e'
+ '6cd698e47c1e803fffc88db6c954708f9b5300fdb37cb6957aaf7845061815f8'
+ '3afcbf1044f780f5cbbde0a0bd8ec8037547e3853544e80c3bd87836092910b2'
+ 'd21b7bcb7aa615f0e0e7af21d8b209f448da928b47c75b61455069eadd3d738d'
+ 'e43cc2bcc12f29cac03f667e480f059e5391c29d075ad7821f1411cea67ac1b1'
+ 'dec92be5e28941f99a0c81c0cb1df8ec76abea6fed58481f412d4a92972bc40c'
+ )
+
+sha256sums_x86_64=('23676122af122dba27616716dd1e3d649dd83c96a80219f97398d2830547a5ee')
+
+package() {
+
+ install -dm755 "$pkgdir/usr/share/applications/"
+ install -d "$pkgdir"/opt/${_pkgbase}/
+ install -Dm755 "$srcdir/linux-unpacked/$pkgbase" "$pkgdir/usr/bin/$pkgbase"
+ mv "$srcdir/linux-unpacked/" "$srcdir/$pkgbase"
+ cp -R "$srcdir/$pkgbase" $pkgdir/opt/
+
+ install -Dm755 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ for icon_size in 16 32 48 64 128 256 512; do
+ icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps"
+ install -d "$icon_dir"
+ install -m644 "$srcdir/${_pkgbase}${icon_size}.png" "$icon_dir/${_pkgbase}.png"
+ done
+}
diff --git a/ndm.desktop b/ndm.desktop
new file mode 100644
index 000000000000..dba5755aabda
--- /dev/null
+++ b/ndm.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=ndm
+Comment=npm desktop manager
+Exec=ndm
+Icon=ndm
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Utility;
diff --git a/ndm128.png b/ndm128.png
new file mode 100644
index 000000000000..d3b630c5e215
--- /dev/null
+++ b/ndm128.png
Binary files differ
diff --git a/ndm16.png b/ndm16.png
new file mode 100644
index 000000000000..981acb77cade
--- /dev/null
+++ b/ndm16.png
Binary files differ
diff --git a/ndm24.png b/ndm24.png
new file mode 100644
index 000000000000..e1f8bc711cd1
--- /dev/null
+++ b/ndm24.png
Binary files differ
diff --git a/ndm256.png b/ndm256.png
new file mode 100644
index 000000000000..a95ce3f70432
--- /dev/null
+++ b/ndm256.png
Binary files differ
diff --git a/ndm32.png b/ndm32.png
new file mode 100644
index 000000000000..4b23f37863d6
--- /dev/null
+++ b/ndm32.png
Binary files differ
diff --git a/ndm48.png b/ndm48.png
new file mode 100644
index 000000000000..27a3e9bc64d1
--- /dev/null
+++ b/ndm48.png
Binary files differ
diff --git a/ndm512.png b/ndm512.png
new file mode 100644
index 000000000000..4368337a0f40
--- /dev/null
+++ b/ndm512.png
Binary files differ
diff --git a/ndm64.png b/ndm64.png
new file mode 100644
index 000000000000..4002901c91eb
--- /dev/null
+++ b/ndm64.png
Binary files differ
diff --git a/ndm96.png b/ndm96.png
new file mode 100644
index 000000000000..ff0faf7f4904
--- /dev/null
+++ b/ndm96.png
Binary files differ