summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2020-09-11 12:34:48 -0400
committerAndrew Sun2020-09-11 12:34:48 -0400
commitdc6bd0e722cd866ed950f4053d534630cfc91f0e (patch)
treee126a45b90ec7804ea6c44659fc70b236e60e28d
parentdd0b418379da3e3b34887f9dee75ff80efb9629c (diff)
downloadaur-dc6bd0e722cd866ed950f4053d534630cfc91f0e.tar.gz
1.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--baresip-flags.patch8
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83a7e6b3ec22..afae487efd59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = baresip
pkgdesc = portable and modular SIP User-Agent with audio and video support
- pkgver = 0.6.6
+ pkgver = 1.0.0
pkgrel = 1
url = http://www.creytiv.com/baresip.html
arch = i686
@@ -45,10 +45,10 @@ pkgbase = baresip
optdepends = spandsp: (g722, g726,plc modules)
optdepends = speexdsp: (speex_aec, speex_pp modules)
optdepends = v4l-utils: (v4l2 module)
- source = baresip-0.6.6.tar.gz::https://github.com/alfredh/baresip/archive/v0.6.6.tar.gz
+ source = baresip-1.0.0.tar.gz::https://github.com/alfredh/baresip/archive/v1.0.0.tar.gz
source = baresip-flags.patch
- sha256sums = e20d744f88e9f5d01aec34ae62c471e3aad143d5f428ad451f111e57eae374c6
- sha256sums = 8344c52dd4b1efe5ed05c42456d1366074b76159a999a525ea6b914ace32ebba
+ sha256sums = 7b008c0a5b4fccfa0a4003f86dc4aaafeaabbdd259ece4757898e9cb5f04fdcf
+ sha256sums = 60b43559bfc00a23f023b80dbc8c7a0600f607e45bc8ba8ef6a786e583cc5d08
pkgname = baresip
diff --git a/PKGBUILD b/PKGBUILD
index 0fa3b0ebc505..dece9b6809a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Andrew Sun <adsun701 at gmail dot com>
# Contributor: Dmitrij D. Czarkoff <czarkoff at gmail dot com>
pkgname=baresip
-pkgver=0.6.6
+pkgver=1.0.0
pkgrel=1
pkgdesc="portable and modular SIP User-Agent with audio and video support"
arch=('i686' 'x86_64' 'armv6h')
@@ -31,8 +31,8 @@ optdepends=('alsa-lib: (alsa module)'
makedepends=(${optdepends[@]/%:*/})
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/alfredh/baresip/archive/v${pkgver}.tar.gz"
"baresip-flags.patch")
-sha256sums=('e20d744f88e9f5d01aec34ae62c471e3aad143d5f428ad451f111e57eae374c6'
- '8344c52dd4b1efe5ed05c42456d1366074b76159a999a525ea6b914ace32ebba')
+sha256sums=('7b008c0a5b4fccfa0a4003f86dc4aaafeaabbdd259ece4757898e9cb5f04fdcf'
+ '60b43559bfc00a23f023b80dbc8c7a0600f607e45bc8ba8ef6a786e583cc5d08')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/baresip-flags.patch b/baresip-flags.patch
index 983c296c3ab0..a21af1e92b17 100644
--- a/baresip-flags.patch
+++ b/baresip-flags.patch
@@ -18,12 +18,12 @@
-L$(LIBRE_SO) -lre $(LIBS) -o $@
-@@ -227,7 +227,7 @@
+@@ -236,7 +236,7 @@
- $(TEST_BIN): $(STATICLIB) $(TEST_OBJS)
+ $(TEST_BIN): $(STATICLIB) $(TEST_OBJS) $(TEST_MODULES)
@echo " LD $@"
-- $(HIDE)$(LD) $(LFLAGS) $(TEST_OBJS) \
-+ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(TEST_OBJS) \
+- $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $(TEST_OBJS) \
++ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(APP_LFLAGS) $(TEST_OBJS) \
-L$(LIBRE_SO) -L. \
-l$(PROJECT) -lre $(LIBS) $(TEST_LIBS) -o $@