summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-02-15 11:13:30 +0100
committerPhilipp A2018-02-15 11:13:30 +0100
commitdc8850df1261b39a8e23fed63d84c0f7046cb6ac (patch)
tree96253f3f2d70775b476215c8c617d3ac5d0d8826
downloadaur-dc8850df1261b39a8e23fed63d84c0f7046cb6ac.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11bf56358112
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-plotnine
+ pkgdesc = A grammar of graphics for python
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/has2k1/plotnine
+ arch = any
+ license = GPL2
+ makedepends = python-pip
+ depends = python
+ depends = python-numpy
+ depends = python-six
+ depends = python-matplotlib>=2.1.0
+ depends = python-mizani>=0.4.1
+ depends = python-pandas>=0.21.0
+ depends = python-patsy>=0.4.1
+ depends = python-scipy>=1.0.0
+ depends = python-statsmodels>=0.8.0
+ noextract = plotnine-0.3.0-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/p/plotnine/plotnine-0.3.0-py2.py3-none-any.whl
+ sha256sums = ed18a7e9f30b685f383f252dd844492a667cc567d06ebf5e9688b941316161ca
+
+pkgname = python-plotnine
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d7ad300862e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.whl
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23c5b8736188
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+_name=plotnine
+pkgname=python-$_name
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='A grammar of graphics for python'
+arch=(any)
+url="https://github.com/has2k1/$_name"
+license=(GPL2)
+depends=(
+ python
+ python-numpy
+ python-six
+ 'python-matplotlib>=2.1.0'
+ 'python-mizani>=0.4.1'
+ 'python-pandas>=0.21.0'
+ 'python-patsy>=0.4.1'
+ 'python-scipy>=1.0.0'
+ 'python-statsmodels>=0.8.0'
+)
+makedepends=(python-pip)
+_wheel="$_name-$pkgver-py2.py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
+noextract=("$_wheel")
+sha256sums=('ed18a7e9f30b685f383f252dd844492a667cc567d06ebf5e9688b941316161ca')
+
+package() {
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+}