summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:27:28 -0700
committerAaron DeVore2015-07-08 11:27:28 -0700
commitdd0b0d514740acccb0a158a6d68bcd8dea0e913c (patch)
tree1c49e241d5195d9f212e7c1a69509956946b9335
downloadaur-dd0b0d514740acccb0a158a6d68bcd8dea0e913c.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--Changelog4
-rw-r--r--PKGBUILD44
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e933c7fbb88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-nevow
+ pkgdesc = Web application construction kit and templating engine written in python.
+ pkgver = 0.10.0
+ pkgrel = 3
+ url = http://divmod.org/trac/wiki/DivmodNevow
+ changelog = Changelog
+ arch = any
+ license = custom
+ makedepends = twisted
+ makedepends = python2-distribute
+ depends = python2
+ optdepends = twisted: to use all the advanced features of nevow, such as LivePage
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/N/Nevow/Nevow-0.10.0.tar.gz
+ md5sums = 66dda2ad88f42dea05911add15f4d1b2
+
+pkgname = python-nevow
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..6718c168ecf3
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,4 @@
+2011-10-23 Aaron DeVore <aaron.devore@gmail.com>
+- Switch from dead divmod link to Python Package Index
+- Cosmetic clean ups
+- Switch from setuptools to python2-distribute
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..788b2eb524c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Marco Elver <el.marcoe+arch at gmail dot com>
+
+pkgname=python-nevow
+pkgver=0.10.0
+pkgrel=3
+arch=(any)
+license=('custom')
+pkgdesc="Web application construction kit and templating engine written in python."
+url="http://divmod.org/trac/wiki/DivmodNevow"
+depends=('python2')
+optdepends=('twisted: to use all the advanced features of nevow, such as LivePage')
+makedepends=('twisted' 'python2-distribute')
+source=("http://pypi.python.org/packages/source/N/Nevow/Nevow-${pkgver}.tar.gz")
+md5sums=('66dda2ad88f42dea05911add15f4d1b2')
+options=(!emptydirs)
+changelog=Changelog
+
+build() {
+ cd $srcdir/Nevow-$pkgver
+ python2 setup.py install --root=$pkgdir --optimize=1
+
+ # is there a way to fix the doc path with the setup.py script ?
+ mkdir -p $pkgdir/usr/share/doc/nevow
+ mv $pkgdir/usr/doc/man $pkgdir/usr/share/
+ mv $pkgdir/usr/doc/* $pkgdir/usr/share/doc/nevow/
+ rm -r $pkgdir/usr/doc
+
+ # Same as above - in v0.9.33 nevow_widget.py was in the right
+ # place. Can anybody explain why this has changed? Let's hope this
+ # gets fixed in their next setup.py.
+ _python_version=`python2 -c "import sys; print sys.version[:3]"`
+ _python_twisted_plugins="$pkgdir/usr/lib/python${_python_version}/site-packages/twisted/plugins/"
+ mkdir -p $_python_twisted_plugins
+ mv $pkgdir/usr/twisted/plugins/nevow_widget.py $_python_twisted_plugins
+ rm -r $pkgdir/usr/twisted
+
+ # Distribute doesn't kill off #!/usr/bin/python shebangs
+ find $pkgdir -name "*.py" -exec \
+ sed -i '1s/python[[:space:]]*$/python2/' {} \;
+
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+