summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-04-12 16:03:53 +0200
committerChristopher Arndt2019-04-12 16:03:53 +0200
commitdd1e74e8c1bc5747bf031ad55fb6de8d412ee1a0 (patch)
tree0b27ed1552815a51d4806e43bc4f3ce24580e1fd
downloadaur-dd1e74e8c1bc5747bf031ad55fb6de8d412ee1a0.tar.gz
Add new package 'peasy-git'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD44
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3fbc8913238
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = peasy-git
+ pkgdesc = A plugin for Geany which allows to load other plugins written in Python or Lua (Git version)
+ pkgver = 0.6.r137.3c8a558
+ pkgrel = 1
+ url = https://github.com/kugel-/peasy/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = vala
+ depends = libpeas
+ depends = geany-gtk3-git
+ optdepends = python: support plugins written in Python
+ optdepends = lua51: support plugins written in Lua
+ provides = peasy
+ conflicts = peasy
+ source = peasy::git+https://github.com/kugel-/peasy.git
+ sha256sums = SKIP
+
+pkgname = peasy-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e8e75c3a589
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+peasy
+peasy-git-*.src.tar.gz
+peasy-git-*.pkg.tar.xz
+.AURINFO
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb38f895969d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=peasy
+pkgname="${_pkgname}-git"
+pkgver=0.6.r137.3c8a558
+pkgrel=1
+pkgdesc="A plugin for Geany which allows to load other plugins written in Python or Lua (Git version)"
+url="https://github.com/kugel-/peasy/"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('libpeas' 'geany-gtk3-git')
+makedepends=('vala')
+optdepends=('python: support plugins written in Python'
+ 'lua51: support plugins written in Lua')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/kugel-/peasy.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ ver=$(grep PACKAGE_VERSION= configure | cut -f 2 -d "'")
+ echo $ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./autogen.sh
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: