summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2022-01-17 20:40:10 +0300
committersurefire2022-01-17 20:40:10 +0300
commitdd2c9a5546d9a35260a73b1c32dd48cb218a14c7 (patch)
treecdfea6ede473f9ee46edbc46265e3a110b38fc4d
parent82d7c5daa3f184d33c3058b48a83d91c0703c393 (diff)
downloadaur-dd2c9a5546d9a35260a73b1c32dd48cb218a14c7.tar.gz
upgpkg: litecoin-git 0.21.1rc1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
-rw-r--r--boost1770.patch56
-rw-r--r--qt515.patch12
4 files changed, 67 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6feaf548ceb..9db9a897873a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = litecoin-git
- pkgver = 0.18.1+0+g81c4f2d80
+ pkgver = 0.21.1rc1+0+g3665dadce
pkgrel = 1
url = http://www.litecoin.org/
arch = x86_64
@@ -13,16 +13,16 @@ pkgbase = litecoin-git
makedepends = qt5-base
makedepends = qt5-tools
makedepends = zeromq
- source = litecoin-git::git+https://github.com/litecoin-project/litecoin.git#branch=0.18
- source = qt515.patch
+ source = litecoin-git::git+https://github.com/litecoin-project/litecoin.git#branch=0.21
source = litecoin-qt.desktop
source = litecoind.service
source = litecoin.sysusers
+ source = boost1770.patch
sha256sums = SKIP
- sha256sums = 97fbaf4f5dca82771a960b545c277a84eadce1eb146e8a61b0a31e73d2df6cc8
sha256sums = ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96
sha256sums = 98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88
sha256sums = a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db
+ sha256sums = 3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5
pkgname = litecoin-daemon-git
pkgdesc = Litecoin is a peer-to-peer network based digital currency - daemon
@@ -59,4 +59,3 @@ pkgname = litecoin-tx-git
depends = openssl
provides = litecoin-tx
conflicts = litecoin-tx
-
diff --git a/PKGBUILD b/PKGBUILD
index 9b28faf22d23..f3c28b762c2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgbase=litecoin-git
pkgname=('litecoin-daemon-git' 'litecoin-cli-git' 'litecoin-qt-git' 'litecoin-tx-git')
-git_branch=0.18
-pkgver=0.18.1+0+g81c4f2d80
+git_branch=0.21
+pkgver=0.21.1rc1+0+g3665dadce
pkgrel=1
arch=('x86_64')
url="http://www.litecoin.org/"
@@ -22,23 +22,23 @@ makedepends=(
)
source=(
"$pkgbase::git+https://github.com/litecoin-project/litecoin.git#branch=$git_branch"
- "qt515.patch"
'litecoin-qt.desktop'
'litecoind.service'
'litecoin.sysusers'
+ 'boost1770.patch'
)
sha256sums=('SKIP'
- '97fbaf4f5dca82771a960b545c277a84eadce1eb146e8a61b0a31e73d2df6cc8'
'ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96'
'98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88'
- 'a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db')
+ 'a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db'
+ '3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5')
prepare() {
cd "$pkgbase"
autoreconf -fi
- patch -Np1 -i ../qt515.patch
+ patch -Np1 -i ../boost1770.patch
}
pkgver() {
@@ -52,11 +52,6 @@ build() {
make
}
-check() {
- cd "$pkgbase"
- make check
-}
-
package_litecoin-qt-git() {
pkgdesc="Litecoin is a peer-to-peer network based digital currency - Qt"
depends=(boost-libs desktop-file-utils libevent qt5-base miniupnpc qrencode protobuf zeromq)
@@ -95,7 +90,7 @@ package_litecoin-cli-git() {
provides=(litecoin-cli)
cd "$pkgbase"
- install -Dt "$pkgdir/usr/bin/litecoin-cli" -m755 src/litecoin-cli
+ install -Dt "$pkgdir/usr/bin" -m755 src/litecoin-cli
install -Dt "$pkgdir/usr/share/man/man1" -m644 doc/man/litecoin-cli.1
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING
}
diff --git a/boost1770.patch b/boost1770.patch
new file mode 100644
index 000000000000..07f8432eddbb
--- /dev/null
+++ b/boost1770.patch
@@ -0,0 +1,56 @@
+commit acb7aad27ec8a184808aa7905887e3b2c5d54e9c
+Author: Rafael Sadowski <rafael@sizeofvoid.org>
+Date: Mon Aug 16 06:34:02 2021 +0200
+
+ Fix build with Boost 1.77.0
+
+ BOOST_FILESYSTEM_C_STR changed to accept the path as an argument
+
+diff --git a/src/fs.cpp b/src/fs.cpp
+index 4f20ca4d2..89c7ad27d 100644
+--- a/src/fs.cpp
++++ b/src/fs.cpp
+@@ -242,7 +242,11 @@ void ofstream::close()
+ }
+ #else // __GLIBCXX__
+
++#if BOOST_VERSION >= 107700
++static_assert(sizeof(*BOOST_FILESYSTEM_C_STR(fs::path())) == sizeof(wchar_t),
++#else
+ static_assert(sizeof(*fs::path().BOOST_FILESYSTEM_C_STR) == sizeof(wchar_t),
++#endif // BOOST_VERSION >= 107700
+ "Warning: This build is using boost::filesystem ofstream and ifstream "
+ "implementations which will fail to open paths containing multibyte "
+ "characters. You should delete this static_assert to ignore this warning, "
+diff --git a/src/wallet/test/db_tests.cpp b/src/wallet/test/db_tests.cpp
+index 17f5264b4..16cb7e0ba 100644
+--- a/src/wallet/test/db_tests.cpp
++++ b/src/wallet/test/db_tests.cpp
+@@ -25,7 +25,11 @@ BOOST_AUTO_TEST_CASE(getwalletenv_file)
+ std::string test_name = "test_name.dat";
+ const fs::path datadir = gArgs.GetDataDirNet();
+ fs::path file_path = datadir / test_name;
++#if BOOST_VERSION >= 107700
++ std::ofstream f(BOOST_FILESYSTEM_C_STR(file_path));
++#else
+ std::ofstream f(file_path.BOOST_FILESYSTEM_C_STR);
++#endif // BOOST_VERSION >= 107700
+ f.close();
+
+ std::string filename;
+diff --git a/src/wallet/test/init_test_fixture.cpp b/src/wallet/test/init_test_fixture.cpp
+index dd9354848..53c972c46 100644
+--- a/src/wallet/test/init_test_fixture.cpp
++++ b/src/wallet/test/init_test_fixture.cpp
+@@ -32,7 +32,11 @@ InitWalletDirTestingSetup::InitWalletDirTestingSetup(const std::string& chainNam
+ fs::create_directories(m_walletdir_path_cases["default"]);
+ fs::create_directories(m_walletdir_path_cases["custom"]);
+ fs::create_directories(m_walletdir_path_cases["relative"]);
++#if BOOST_VERSION >= 107700
++ std::ofstream f(BOOST_FILESYSTEM_C_STR(m_walletdir_path_cases["file"]));
++#else
+ std::ofstream f(m_walletdir_path_cases["file"].BOOST_FILESYSTEM_C_STR);
++#endif // BOOST_VERSION >= 107700
+ f.close();
+ }
+
diff --git a/qt515.patch b/qt515.patch
deleted file mode 100644
index 6fe317fc8e1f..000000000000
--- a/qt515.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
-index 1588be8da..b0091ada3 100644
---- a/src/qt/trafficgraphwidget.cpp
-+++ b/src/qt/trafficgraphwidget.cpp
-@@ -7,6 +7,7 @@
- #include <qt/clientmodel.h>
-
- #include <QPainter>
-+#include <QPainterPath>
- #include <QColor>
- #include <QTimer>
-