aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-07-23 20:34:55 -0400
committerSolomon Choina2020-07-23 20:34:55 -0400
commitdd37a69a9efe7e7c9757252a6f901256805e793f (patch)
tree378503d3523ba1d57241bc26323107513dce6d8d
parent747275a5244f94a43d234e5a82b7baa33fa37ab6 (diff)
downloadaur-dd37a69a9efe7e7c9757252a6f901256805e793f.tar.gz
update gtk3 for hooks
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD38
-rw-r--r--gtk-query-immodules-3.0.hook11
-rw-r--r--gtk-update-icon-cache.hook13
-rw-r--r--gtk-update-icon-cache.script10
-rw-r--r--settings.ini2
6 files changed, 80 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1faf7f2ec301..502db21b3dd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed Dec 23 16:50:51 UTC 2015
pkgbase = gtk3-git
pkgdesc = GObject-based multi-platform GUI toolkit (GIT Version)
- pkgver = 3.19.5.r193.ge20826f
+ pkgver = 3.24.21.r45.g63a0e76646
pkgrel = 1
url = http://www.gtk.org/
- install = gtk3-git.install
arch = i686
arch = x86_64
license = LGPL
- makedepends = gobject-introspection-git
+ makedepends = gobject-introspection
depends = at-spi2-atk
- depends = atk-git
+ depends = atk
depends = cairo
depends = colord
- depends = glib2-git>=2.45.8
+ depends = glib2
depends = gtk-update-icon-cache
depends = libcups
depends = libepoxy
@@ -25,21 +22,31 @@ pkgbase = gtk3-git
depends = libxinerama
depends = libxkbcommon
depends = libxrandr
- depends = pango-git
+ depends = pango
depends = shared-mime-info
- depends = wayland-git
- depends = wayland-protocols-git
+ depends = wayland
+ depends = wayland-protocols
optdepends = gnome-icon-theme: Default icon theme
optdepends = gnome-themes-standard: Default widget theme
- provides = gtk3=3.19.5.r193.ge20826f
+ provides = gtk3=3.24.21.r45.g63a0e76646
provides = gtk-update-icon-cache
+ provides = gtk3-print-backends
+ provides = libgtk-3.so
+ provides = libgdk-3.so
+ provides = libgailutil-3.so
conflicts = gtk3
conflicts = gtk-update-icon-cache
backup = usr/share/gtk-3.0/settings.ini
- source = git://git.gnome.org/gtk+
+ source = git+https://gitlab.gnome.org/GNOME/gtk.git#branch=gtk-3-24
source = settings.ini
- md5sums = SKIP
- md5sums = 52bca1105d029c5142909b9e349bb89c
+ source = gtk-query-immodules-3.0.hook
+ source = gtk-update-icon-cache.hook
+ source = gtk-update-icon-cache.script
+ sha256sums = SKIP
+ sha256sums = 01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202
+ sha256sums = a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229
+ sha256sums = 2d435e3bec8b79b533f00f6d04decb1d7c299c6e89b5b175f20be0459f003fe8
+ sha256sums = f1d3a0dbfd82f7339301abecdbe5f024337919b48bd0e09296bb0e79863b2541
pkgname = gtk3-git
diff --git a/PKGBUILD b/PKGBUILD
index ec81d7e31aeb..0987297a6528 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,42 @@
# Contributor: Boohbah <boohbah at gmail.com>
pkgname=gtk3-git
-pkgver=3.19.5.r193.ge20826f
+pkgver=3.24.21.r45.g63a0e76646
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (GIT Version)"
arch=('i686' 'x86_64')
url="http://www.gtk.org/"
license=('LGPL')
-depends=('at-spi2-atk' 'atk-git' 'cairo' 'colord' 'glib2-git>=2.45.8'
+depends=('at-spi2-atk' 'atk' 'cairo' 'colord' 'glib2'
'gtk-update-icon-cache' 'libcups' 'libepoxy' 'libxcomposite'
'libxcursor' 'libxdamage' 'libxi' 'libxinerama'
- 'libxkbcommon' 'libxrandr' 'pango-git' 'shared-mime-info'
- 'wayland-git' 'wayland-protocols-git')
-makedepends=('gobject-introspection-git')
+ 'libxkbcommon' 'libxrandr' 'pango' 'shared-mime-info'
+ 'wayland' 'wayland-protocols')
+makedepends=('gobject-introspection')
optdepends=('gnome-icon-theme: Default icon theme'
'gnome-themes-standard: Default widget theme')
conflicts=('gtk3' 'gtk-update-icon-cache')
-provides=("gtk3=$pkgver" 'gtk-update-icon-cache')
+provides=("gtk3=$pkgver" gtk-update-icon-cache gtk3-print-backends libgtk-3.so libgdk-3.so libgailutil-3.so)
backup=('usr/share/gtk-3.0/settings.ini')
-install="gtk3-git.install"
-source=('git://git.gnome.org/gtk+' 'settings.ini')
-md5sums=('SKIP'
- '52bca1105d029c5142909b9e349bb89c')
+source=('git+https://gitlab.gnome.org/GNOME/gtk.git#branch=gtk-3-24'
+ settings.ini
+ gtk-query-immodules-3.0.hook
+ gtk-update-icon-cache.hook
+ gtk-update-icon-cache.script)
+sha256sums=('SKIP'
+ '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202'
+ 'a0319b6795410f06d38de1e8695a9bf9636ff2169f40701671580e60a108e229'
+ '2d435e3bec8b79b533f00f6d04decb1d7c299c6e89b5b175f20be0459f003fe8'
+ 'f1d3a0dbfd82f7339301abecdbe5f024337919b48bd0e09296bb0e79863b2541')
pkgver() {
- cd "gtk+"
+ cd "gtk"
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "gtk+"
+ cd "gtk"
./autogen.sh --disable-schemas-compile \
--enable-broadway-backend \
@@ -50,10 +56,14 @@ build() {
}
package() {
- cd "gtk+"
+ cd "gtk"
make DESTDIR="$pkgdir" install
- install -Dm644 "../settings.ini" "$pkgdir/usr/share/gtk-3.0/settings.ini"
+ install -Dt "$pkgdir/usr/share/gtk-3.0" -m644 ../settings.ini
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../gtk-query-immodules-3.0.hook
+
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../gtk-update-icon-cache.hook
+ install -D ../gtk-update-icon-cache.script "$pkgdir/usr/share/libalpm/scripts/gtk-update-icon-cache"
}
diff --git a/gtk-query-immodules-3.0.hook b/gtk-query-immodules-3.0.hook
new file mode 100644
index 000000000000..4d81bd713910
--- /dev/null
+++ b/gtk-query-immodules-3.0.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = Path
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gtk-3.0/3.0.0/immodules/*.so
+
+[Action]
+Description = Probing GTK3 input method modules...
+When = PostTransaction
+Exec = /usr/bin/gtk-query-immodules-3.0 --update-cache
diff --git a/gtk-update-icon-cache.hook b/gtk-update-icon-cache.hook
new file mode 100644
index 000000000000..758a62187a9b
--- /dev/null
+++ b/gtk-update-icon-cache.hook
@@ -0,0 +1,13 @@
+[Trigger]
+Type = Path
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/icons/*/
+Target = !usr/share/icons/*/?*
+
+[Action]
+Description = Updating icon theme caches...
+When = PostTransaction
+Exec = /usr/share/libalpm/scripts/gtk-update-icon-cache
+NeedsTargets
diff --git a/gtk-update-icon-cache.script b/gtk-update-icon-cache.script
new file mode 100644
index 000000000000..ee0f1d12d0b7
--- /dev/null
+++ b/gtk-update-icon-cache.script
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+while read -r f; do
+ if [[ -e ${f}index.theme ]]; then
+ gtk-update-icon-cache -q "$f"
+ elif [[ -d $f ]]; then
+ rm -f "${f}icon-theme.cache"
+ rmdir --ignore-fail-on-non-empty "$f"
+ fi
+done
diff --git a/settings.ini b/settings.ini
index 6a0643bfa67e..921d1ddeec01 100644
--- a/settings.ini
+++ b/settings.ini
@@ -1,4 +1,4 @@
[Settings]
-gtk-icon-theme-name = gnome
+gtk-icon-theme-name = Adwaita
gtk-theme-name = Adwaita
gtk-font-name = Cantarell 11