summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-08 15:46:39 -0400
committerGuillaume Horel2017-07-08 15:47:06 -0400
commitdd543dc125e6fa256307ad4b4fa5c0e296d9decd (patch)
tree50f23d2e2269d39416389222ef747a1511906bb7
parent584bb31c46d726ad0cb68478e41f8d80b7f37c05 (diff)
downloadaur-dd543dc125e6fa256307ad4b4fa5c0e296d9decd.tar.gz
version bump
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
-rw-r--r--flexisip-presence.service12
-rw-r--r--flexisip.service6
4 files changed, 40 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45f1b074e6c2..347f1d20f493 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
pkgbase = flexisip
pkgdesc = A general purpose SIP proxy with media capabilities
pkgver = 1.0.10
- pkgrel = 2
+ pkgrel = 3
url = http://flexisip.org
arch = i686
arch = x86_64
license = AGPL3
- depends = belle-sip
- depends = boost-libs
+ makedepends = cmake
+ depends = belle-sip-git
depends = hiredis
- depends = mediastreamer
+ depends = mediastreamer-git
+ depends = ortp-git
depends = protobuf
+ depends = soci
depends = sofia-sip-bc
depends = unixodbc
depends = xsd
- depends = soci
- source = git+https://github.com/BelleDonneCommunications/flexisip.git#commit=cf47b79bd656
+ source = git+https://github.com/BelleDonneCommunications/flexisip.git#commit=d915601df292742c61b188d1184b376eabf47c83
source = flexisip.service
+ source = flexisip-presence.service
sha256sums = SKIP
- sha256sums = 2a96c6604c62ea6b70f0bd6e96c6910afef6e17ac8d44ce0a50cce60279946be
+ sha256sums = 5c16f7a064ad93d75b9bc4401a5c651ca303ff2b92452e86b9a53ef674db93e4
+ sha256sums = 7f658cc393ef2feab587aaacc7cb62c1211620aa846c6b860c775272d698675c
pkgname = flexisip
diff --git a/PKGBUILD b/PKGBUILD
index cb3b9670f17d..22a1a4896cd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,29 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=flexisip
pkgver=1.0.10
-pkgrel=2
+pkgrel=3
pkgdesc="A general purpose SIP proxy with media capabilities"
arch=('i686' 'x86_64')
url="http://flexisip.org"
license=('AGPL3')
groups=()
-depends=('belle-sip' 'boost-libs' 'hiredis' 'mediastreamer' 'protobuf' 'sofia-sip-bc' 'unixodbc' 'xsd' 'soci')
-makedepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("git+https://github.com/BelleDonneCommunications/$pkgname.git#commit=cf47b79bd656"
- "flexisip.service")
+depends=('belle-sip-git' 'hiredis' 'mediastreamer-git' 'ortp-git' 'protobuf' 'soci' 'sofia-sip-bc' 'unixodbc' 'xsd')
+makedepends=('cmake')
+source=("git+https://github.com/BelleDonneCommunications/$pkgname.git#commit=d915601df292742c61b188d1184b376eabf47c83"
+ "flexisip.service"
+ "flexisip-presence.service")
noextract=()
sha256sums=('SKIP'
- '2a96c6604c62ea6b70f0bd6e96c6910afef6e17ac8d44ce0a50cce60279946be')
+ '5c16f7a064ad93d75b9bc4401a5c651ca303ff2b92452e86b9a53ef674db93e4'
+ '7f658cc393ef2feab587aaacc7cb62c1211620aa846c6b860c775272d698675c')
build() {
- cd "$pkgname"
-
- ./autogen.sh
- ./configure --prefix=/usr \
- --mandir=/usr/share/man \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --libdir=/usr/lib \
- --enable-odbc \
- --enable-presence \
- --enable-protobuf \
- --enable-redis \
- --enable-transcoder \
- --disable-doc \
- --disable-strict
+ cd "$pkgname"
+ cmake -DCMAKE_INTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DENABLE_REDIS=YES \
+ -DENABLE_PROTOBUF=YES \
+ -DENABLE_PRESENCE=YES .
make
}
@@ -48,4 +32,5 @@ package() {
make DESTDIR="$pkgdir/" install
install -Dm0644 "$srcdir/flexisip.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
+ install -Dm0644 "$srcdir/flexisip-presence.service" "$pkgdir/usr/lib/systemd/system/flexisip.service"
}
diff --git a/flexisip-presence.service b/flexisip-presence.service
new file mode 100644
index 000000000000..92e23d655db7
--- /dev/null
+++ b/flexisip-presence.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Flexisip presence server
+Documentation=http://www.linphone.org/technical-corner/flexisip/overview
+After=syslog.target network.service network.target redis.service mysqld.service
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/flexisip --server presence --daemon --syslog --pidfile /run/flexisip-presence.pid
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/flexisip.service b/flexisip.service
index 516ab2416a4e..f60024761147 100644
--- a/flexisip.service
+++ b/flexisip.service
@@ -1,10 +1,10 @@
[Unit]
-Description=Flexisip server
-After=network.target
+Description=Flexisip proxy server
+After=syslog.target network.service network.target redis.service mysqld.service
[Service]
Type=forking
-ExecStart=/usr/bin/flexisip --daemon -p /run/flexisip.pid
+ExecStart=/usr/bin/flexisip --server proxy --daemon -p /run/flexisip.pid
PIDFile=/run/flexisip.pid
[Install]