summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorz3ntu2016-02-23 15:12:03 +0100
committerz3ntu2016-02-23 15:12:03 +0100
commitdd57e2daae5494ef298786162ee3d944b34bc5b0 (patch)
tree718f1d4550087967fd06d11e4be6e5b8a398c5f8
downloadaur-dd57e2daae5494ef298786162ee3d944b34bc5b0.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef9259123fca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Feb 23 14:00:12 UTC 2016
+pkgbase = python-pkgbuild-git
+ pkgdesc = Python library to parse pacman's .SRCINFO file
+ pkgver = r3.aeca84e
+ pkgrel = 1
+ url = https://github.com/z3ntu/python-pkgbuild
+ arch = any
+ license = MIT
+ depends = python
+ options = !emptydirs
+ source = git+https://github.com/z3ntu/python-pkgbuild
+ md5sums = SKIP
+
+pkgname = python-pkgbuild-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2b4945020cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+pkgname=python-pkgbuild-git
+pkgver=r3.aeca84e
+pkgrel=1
+pkgdesc="Python library to parse pacman's .SRCINFO file"
+arch=('any')
+url="https://github.com/z3ntu/python-pkgbuild"
+license=('MIT')
+depends=('python')
+options=(!emptydirs)
+source=(git+https://github.com/z3ntu/python-pkgbuild)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/python-pkgbuild"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/python-pkgbuild"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+