summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKazuo Teramoto2017-01-25 23:01:38 -0200
committerKazuo Teramoto2017-01-25 23:01:38 -0200
commitdd5be044881376997cf9604961a8e461ef54e308 (patch)
tree608bcc08e081538931276c26092e628392977381
downloadaur-dd5be044881376997cf9604961a8e461ef54e308.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3a77bf46095
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-urwidtrees-git
+ pkgdesc = Tree widgets for urwid
+ pkgver = 1.0.2.r35.9142c59
+ pkgrel = 1
+ url = https://github.com/pazz/urwidtrees
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-sphinx
+ depends = python-urwid>=1.1.0
+ depends = python-mock
+ provides = python-urwidtrees
+ conflicts = python-urwidtrees
+ source = git+https://github.com/pazz/urwidtrees.git
+ sha256sums = SKIP
+
+pkgname = python-urwidtrees-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bc5ed4e063a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kazuo Teramoto <kaz.rag at gmail dot com>
+
+pkgname=python-urwidtrees-git
+pkgver=1.0.2.r35.9142c59
+pkgrel=1
+pkgdesc="Tree widgets for urwid"
+arch=("any")
+url="https://github.com/pazz/urwidtrees"
+license=("GPL")
+depends=("python-urwid>=1.1.0" "python-mock")
+makedepends=("git" "python-sphinx")
+provides=('python-urwidtrees')
+conflicts=('python-urwidtrees')
+source=("git+https://github.com/pazz/urwidtrees.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd urwidtrees
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd urwidtrees
+ python setup.py build
+}
+
+package() {
+ cd urwidtrees
+ python setup.py install --root="${pkgdir}" --skip-build
+}