summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-12-13 17:22:31 +0100
committerFabioLolix2021-12-13 17:22:31 +0100
commitddb93f693285259203f58c52ec087155c58ac1e3 (patch)
tree168a52ee74dcca3f7d7bd1651f82217582577122
parent477fd3636e901787ed5c4d29b2eb626c63b3d9f0 (diff)
downloadaur-ddb93f693285259203f58c52ec087155c58ac1e3.tar.gz
revision
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1113b5be5bca..a1872ad8b35d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ghostwriter-git
- pkgdesc = ghostwriter is a cross-platform, aesthetic, distraction-free Markdown editor.
- pkgver = v1.8.0.r0.g78d7f3a
+ pkgdesc = Cross-platform, aesthetic, distraction-free Markdown editor.
+ pkgver = 2.1.0.r0.g2495f9b
pkgrel = 1
url = https://github.com/wereturtle/ghostwriter
arch = i686
@@ -13,13 +13,12 @@ pkgbase = ghostwriter-git
depends = hunspell
depends = desktop-file-utils
depends = gtk-update-icon-cache
- depends = markdown
+ depends = discount
depends = qt5-webengine
optdepends = hunspell: spell checking
provides = ghostwriter
conflicts = ghostwriter
- source = git://github.com/wereturtle/ghostwriter.git
+ source = git+https://github.com/wereturtle/ghostwriter.git
sha256sums = SKIP
pkgname = ghostwriter-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 762d7d59abca..1f1151c3d211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org>
+# Contributor: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
pkgname=ghostwriter-git
-pkgver=v1.8.0.r0.g78d7f3a
+pkgver=2.1.0.r0.g2495f9b
pkgrel=1
-pkgdesc="ghostwriter is a cross-platform, aesthetic, distraction-free Markdown editor."
+pkgdesc="Cross-platform, aesthetic, distraction-free Markdown editor."
arch=(i686 x86_64)
url="https://github.com/wereturtle/ghostwriter"
license=('GPL3')
-source=(git://github.com/wereturtle/ghostwriter.git)
-sha256sums=('SKIP')
conflicts=('ghostwriter')
provides=('ghostwriter')
makedepends=('git' 'qt5-tools')
depends=('qt5-base' 'qt5-svg' 'hunspell' 'desktop-file-utils'
- 'gtk-update-icon-cache' 'markdown' 'qt5-webengine')
+ 'gtk-update-icon-cache' 'discount' 'qt5-webengine')
optdepends=('hunspell: spell checking')
+source=(git+https://github.com/wereturtle/ghostwriter.git)
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {