summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2018-05-23 12:21:16 -0400
committerGI_Jack2018-05-23 12:21:16 -0400
commitddc7eb9eada24896fc7ad280489c2e2affc37269 (patch)
tree152d49e658d3f639e961211474392822b13add38
downloadaur-ddc7eb9eada24896fc7ad280489c2e2affc37269.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c4f3c064033
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed May 23 16:21:07 UTC 2018
+pkgbase = dumpzilla-git
+ pkgdesc = Extract All Forensic Interesting Information Of Firefox, Iceweasel And Seamonkey
+ pkgver = r41.73d82d9
+ pkgrel = 1
+ url = http://www.dumpzilla.org/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = python-lz4
+ depends = python-magic
+ provides = dumpzilla
+ conflicts = dumpzilla
+ source = dumpzilla::git+https://github.com/Busindre/dumpzilla.git
+ sha256sums = SKIP
+
+pkgname = dumpzilla-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..497774f95c2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+
+pkgname=dumpzilla-git
+_pkgname=${pkgname%-git}
+pkgver=r41.73d82d9
+pkgrel=1
+pkgdesc="Extract All Forensic Interesting Information Of Firefox, Iceweasel And Seamonkey"
+arch=('any')
+url="http://www.dumpzilla.org/"
+license=('GPL')
+groups=()
+depends=('python' 'python-lz4' 'python-magic')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${_pkgname}::git+https://github.com/Busindre/dumpzilla.git")
+noextract=()
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+#prepare() {
+# cd "$srcdir/${_pkgname}"
+# patch -p1 -i "$srcdir/${_pkgname}.patch"
+#}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ # copy main program
+ mkdir -p "${pkgdir}/usr/share/dumpzilla"
+ install -Dm755 dumpzilla.py "${pkgdir}/usr/share/dumpzilla/dumpzilla.py"
+ cp -r ES_templates_dumpzilla "${pkgdir}/usr/share/dumpzilla/"
+ install -d "${pkgdir}/usr/bin/"
+ echo '/usr/share/dumpzilla/dumpzilla.py ${@}' > "${pkgdir}/usr/bin/dumpzilla"
+ chmod 755 "${pkgdir}/usr/bin/dumpzilla"
+
+ # copy autocomplete
+ install -Dm644 dumpzilla "${pkgdir}/usr/share/bash-completion/completions/dumpzilla"
+}