summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Sever2022-12-22 20:27:26 +0300
committerYigit Sever2022-12-22 20:27:26 +0300
commitddeeb18e4ec12ae712495e8f87450a291b0c3178 (patch)
tree3b54063f373cf6d41e405856c8282204b3870792
parent4e60cc6c00a83f75c3ddc4b7d97a80069035f200 (diff)
downloadaur-ddeeb18e4ec12ae712495e8f87450a291b0c3178.tar.gz
helmsman: Update to 3.15.1-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afe4a0df7bb0..a8ab0dd88f9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = helmsman
pkgdesc = Helm Charts as Code
- pkgver = 3.6.3
+ pkgver = 3.15.1
pkgrel = 1
url = https://github.com/Praqma/helmsman
arch = x86_64
arch = i686
license = MIT
makedepends = go
+ depends = helm
depends = helm-diff
depends = kubectl
optdepends = ruby-hiera-eyaml: backend for secret encryption
optdepends = helm-secrets: backend for secret encryption
- source = https://github.com/Praqma/helmsman/archive/v3.6.3/helmsman-3.6.3.tar.gz
- sha256sums = 05ce86066028ed0fbb99902018953107432727abe297745de4013815b5bf6781
+ source = helmsman-3.15.1.tar.gz::https://github.com/Praqma/helmsman/archive/v3.15.1/helmsman-3.15.1.tar.gz
+ sha256sums = e52b4ae1321906cea08cc01cd78e147167e01491d09a481dbf867ce904de36dd
pkgname = helmsman
-
diff --git a/PKGBUILD b/PKGBUILD
index 048e58add54d..04fb0de30770 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: ml <ml@visu.li>
+# Maintainer: Yigit Sever <yigit at yigitsever dot com>
+# Contributor: ml <ml@visu.li>
# to build in clean chroot build helm-diff from AUR, then pass to build cmd:
# $ extra-x86_64-build -- -I helm-diff-3.1.3-2-x86_64.pkg.tar.zst
+
pkgname=helmsman
-pkgver=3.6.3
+pkgver=3.15.1
pkgrel=1
pkgdesc='Helm Charts as Code'
arch=('x86_64' 'i686')
url='https://github.com/Praqma/helmsman'
license=('MIT')
-depends=('helm-diff' 'kubectl')
+depends=('helm' 'helm-diff' 'kubectl')
optdepends=(
'ruby-hiera-eyaml: backend for secret encryption'
'helm-secrets: backend for secret encryption')
makedepends=('go')
-source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('05ce86066028ed0fbb99902018953107432727abe297745de4013815b5bf6781')
+source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('e52b4ae1321906cea08cc01cd78e147167e01491d09a481dbf867ce904de36dd')
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
@@ -26,18 +28,18 @@ build() {
export GOFLAGS='-buildmode=pie -modcacherw -mod=readonly -trimpath'
# man makepkg(8), https://github.com/Praqma/helmsman/blob/master/Makefile
TZ=UTC printf -v _date '%(%d%m%y)T' "${SOURCE_DATE_EPOCH:- -1}"
- go build -ldflags "-linkmode=external -X main.version=v$pkgver-$_date" ./cmd/helmsman
+ go build -ldflags "-linkmode=external -X main.version=v${pkgver}-${_date}" ./cmd/helmsman
}
check() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
go test -short ./...
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 "$pkgname" -t "$pkgdir/usr/bin"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
# README, docs and examples
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"