summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2020-10-19 04:10:06 +0200
committerTim Schumacher2020-10-19 04:10:06 +0200
commitddf4337b1665083cf2f3fe7c774a293a4b1305ae (patch)
tree042369e3ac5ff4a1fe23b799dd0453bbb97dd12e
downloadaur-ddf4337b1665083cf2f3fe7c774a293a4b1305ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7042fba4512e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mipsr5900el-unknown-linux-gnu-linux-api-headers
+ pkgdesc = Kernel headers sanitized for use in userspace (mipsr5900el-unknown-linux-gnu)
+ pkgver = 5.4
+ pkgrel = 1
+ url = https://github.com/frno7/linux
+ arch = any
+ license = GPL2
+ source = git+https://github.com/frno7/linux#branch=ps2-v5.4
+ sha1sums = SKIP
+
+pkgname = mipsr5900el-unknown-linux-gnu-linux-api-headers
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..290201d085e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+
+linux/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daf917a5c8b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintianer: Tim Schumacher <timschumi@gmx.de>
+
+_target_arch=mips
+_target=mipsr5900el-unknown-linux-gnu
+pkgname=$_target-linux-api-headers
+pkgver=5.4
+pkgrel=1
+pkgdesc="Kernel headers sanitized for use in userspace ($_target)"
+arch=(any)
+url='https://github.com/frno7/linux'
+license=(GPL2)
+source=(git+https://github.com/frno7/linux#branch=ps2-v${pkgver})
+sha1sums=('SKIP')
+
+prepare() {
+ cd linux
+
+ # MIPS: PS2: Add "WITH Linux-syscall-note" to GS and GIF header files
+ git cherry-pick 1aeb7fdf7a6107d5e7be8b518dcec27127ea854c
+}
+
+build() {
+ cd linux
+
+ make ARCH=$_target_arch mrproper
+ make ARCH=$_target_arch headers_check
+}
+
+package() {
+ cd linux
+
+ make ARCH=$_target_arch INSTALL_HDR_PATH="$pkgdir/usr/$_target" headers_install
+
+ # clean-up unnecessary files generated during install
+ find "$pkgdir" \( -name .install -or -name ..install.cmd \) -delete
+}