summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-11 13:35:10 -0400
committerGuillaume Horel2017-07-11 13:35:10 -0400
commitde05ce69bb2db6a371e82fc80b7305acc72d8463 (patch)
tree81ef2a8ff8a630f9a195a9d536c16a8b9ab01f6b
downloadaur-de05ce69bb2db6a371e82fc80b7305acc72d8463.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edeb5edefca5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dash-html-components
+ pkgdesc = HTML components for dash.
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://plot.ly/dash/dash-html-components
+ arch = any
+ license = MIT
+ checkdepends = python-dash
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/cf/05/a33843c06643a492ae593f98cdcaaa5674ec4ad5025e53c0ff2918d60840/dash_html_components-0.6.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = dash-html-components
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eea374c7338b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=dash-html-components
+_pkgname=dash_html_components
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="HTML components for dash."
+arch=('any')
+url="https://plot.ly/dash/dash-html-components"
+license=('MIT')
+depends=('python')
+optdepends=()
+checkdepends=('python-dash')
+makedepends=('git' 'python-setuptools')
+source=("https://pypi.python.org/packages/cf/05/a33843c06643a492ae593f98cdcaaa5674ec4ad5025e53c0ff2918d60840/dash_html_components-$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+#check(){
+# cd "$srcdir/$pkgname"
+# python -m unittest
+#}
+# vim:ts=2:sw=2:et: