summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-08-04 13:45:01 -0400
committerAndrew Sun2018-08-04 13:45:01 -0400
commitde0dd84ad9d707a2a110f3c77f6c83411d40e007 (patch)
tree2f6c10cabf2a6ad68cc04573eec3bada3622aad9
downloadaur-de0dd84ad9d707a2a110f3c77f6c83411d40e007.tar.gz
add mingw-w64-gtkmm3 (version 3.22.2)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f58237330c91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-gtkmm3
+ pkgdesc = C++ bindings for GTK+ 3 (mingw-w64)
+ pkgver = 3.22.2
+ pkgrel = 1
+ url = http://www.gtkmm.org/
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-gtk3
+ depends = mingw-w64-pangomm
+ depends = mingw-w64-atkmm
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.gnome.org/sources/gtkmm/3.22/gtkmm-3.22.2.tar.xz
+ sha256sums = 91afd98a31519536f5f397c2d79696e3d53143b80b75778521ca7b48cb280090
+
+pkgname = mingw-w64-gtkmm3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7059d5b34edb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+pkgname=mingw-w64-gtkmm3
+_pkgname=gtkmm3
+pkgver=3.22.2
+pkgrel=1
+pkgdesc="C++ bindings for GTK+ 3 (mingw-w64)"
+url="http://www.gtkmm.org/"
+arch=('any')
+license=('LGPL')
+depends=('mingw-w64-gtk3' 'mingw-w64-pangomm' 'mingw-w64-atkmm')
+makedepends=('mingw-w64-configure')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("https://download.gnome.org/sources/gtkmm/${pkgver%.*}/gtkmm-${pkgver}.tar.xz")
+sha256sums=('91afd98a31519536f5f397c2d79696e3d53143b80b75778521ca7b48cb280090')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/gtkmm-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --disable-documentation \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/gtkmm-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}/usr/${_arch}" -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ done
+}