summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzombiepantslol2015-06-10 02:41:19 +0200
committerzombiepantslol2015-06-10 02:41:19 +0200
commitde22c8bd8c2ec2fb03ac6c80df6d69748fc93027 (patch)
tree827efb0d6dc6621183092cd2e743a02fc3e6626a
downloadaur-de22c8bd8c2ec2fb03ac6c80df6d69748fc93027.tar.gz
Initial AUR4 import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD52
-rw-r--r--ikea.desktop10
-rw-r--r--iked.conf9
-rw-r--r--iked.service10
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbbab4fdc84e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = shrew-vpn-client
+ pkgdesc = A portable VPN client for Linux with Qt GUI
+ pkgver = 2.2.1
+ pkgrel = 2
+ url = http://www.shrew.net/
+ arch = i686
+ arch = x86_64
+ license = osi
+ makedepends = gcc
+ makedepends = flex
+ makedepends = libedit
+ makedepends = bison
+ makedepends = cmake
+ depends = qt4
+ depends = openssl
+ optdepends = openldap
+ optdepends = logrotate
+ conflicts = shrew-vpn-client-alpha
+ backup = etc/iked.conf
+ source = http://www.shrew.net/download/ike/ike-2.2.1-release.tbz2
+ source = ikea.desktop
+ source = iked.conf
+ source = iked.service
+ md5sums = 8fc14ac86771ee693d3950757c84f335
+ md5sums = 5b35a4246eb1b7bd4bfb6780c23d39f2
+ md5sums = 3cfe649578267235d60ab7cfb6fb4c57
+ md5sums = e90d5922d37f9e45515c5754a3a29c73
+
+pkgname = shrew-vpn-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6be1a11595ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Christian Hammacher <bmasterc gmail com>
+# Contributor: Christian Hammacher <bmasterc gmail com>
+
+pkgname=shrew-vpn-client
+pkgver=2.2.1
+pkgrel=2
+pkgdesc="A portable VPN client for Linux with Qt GUI"
+arch=('i686' 'x86_64')
+url="http://www.shrew.net/"
+license=('osi')
+depends=('qt4' 'openssl')
+makedepends=('gcc' 'flex' 'libedit' 'bison' 'cmake')
+optdepends=('openldap' 'logrotate')
+conflicts=('shrew-vpn-client-alpha')
+backup=('etc/iked.conf')
+source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tbz2"
+ 'ikea.desktop'
+ 'iked.conf'
+ 'iked.service')
+md5sums=('8fc14ac86771ee693d3950757c84f335'
+ '5b35a4246eb1b7bd4bfb6780c23d39f2'
+ '3cfe649578267235d60ab7cfb6fb4c57'
+ 'e90d5922d37f9e45515c5754a3a29c73')
+
+build() {
+ cd $srcdir/ike
+
+ # Build the whole package
+ cmake -DQTGUI=YES -DNATT=YES -DLDAP=YES -DSBINDIR=/usr/bin \
+ -DCMAKE_INSTALL_PREFIX=/usr -DMANDIR=/usr/share/man -DETCDIR=/etc
+ make
+}
+
+package() {
+ cd "$srcdir/ike"
+ make DESTDIR="$pkgdir/" install
+
+ # Install the daemon script
+ install -D -m644 $startdir/iked.service $pkgdir/usr/lib/systemd/system/iked.service
+
+ # The configuration file is already ready for use; just rename it
+ mv $pkgdir/etc/iked.conf.sample $pkgdir/etc/iked.conf
+
+ # Prevent logs from growing if logrotate is installed
+ install -D -m644 $startdir/iked.conf $pkgdir/etc/logrotate.d/iked.conf
+
+ # Copy our desktop files
+ install -D -m644 $srcdir/ike/source/qikea/png/ikea.png $pkgdir/usr/share/icons/ikea.png
+ install -D -m755 $startdir/ikea.desktop $pkgdir/usr/share/applications/ikea.desktop
+}
+
+
diff --git a/ikea.desktop b/ikea.desktop
new file mode 100644
index 000000000000..d79938ba928f
--- /dev/null
+++ b/ikea.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+GenericName=Shrew VPN Client
+Comment=VPN Client
+Name=Shrew VPN Client
+Exec=qikea
+Icon=/usr/share/icons/ikea.png
+Type=Application
+Terminal=false
+Categories=Application;Network;
diff --git a/iked.conf b/iked.conf
new file mode 100644
index 000000000000..a2efe9135c59
--- /dev/null
+++ b/iked.conf
@@ -0,0 +1,9 @@
+/var/log/iked.log {
+ notifempty
+ missingok
+ copytruncate
+ rotate 1
+ compress
+ weekly
+}
+
diff --git a/iked.service b/iked.service
new file mode 100644
index 000000000000..a5ce605c45d1
--- /dev/null
+++ b/iked.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=iked daemon
+After=syslog.target network.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/iked
+
+[Install]
+WantedBy=multi-user.target