summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-05-10 16:24:28 +0200
committerCarsten Teibes2015-05-10 16:24:28 +0200
commitde30e2726b38efe2b321b811c6ac39749272341b (patch)
treeb9bca029e7555a3ee77bf9f07694821801a66f4d
parent89e72022a571971e5b296b229c7c65ef8605cad8 (diff)
downloadaur-de30e2726b38efe2b321b811c6ac39749272341b.tar.gz
[fix] Add a hack to detect installed ruby version,
change fluidsynth dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--mkxp.install6
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e2cd38d0093..8dbd7aac9126 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkxp-git
- pkgdesc = Open source implementation of the Ruby Game Scripting System of RPG Maker XP (development version)
- pkgver = r470.151a1f0
+ pkgdesc = Open source implementation of the Ruby Game Scripting System of RPG Maker XP/VX/VX Ace (development version)
+ pkgver = r745.794e86d
pkgrel = 1
url = https://github.com/Ancurio/mkxp
install = mkxp.install
@@ -14,6 +14,7 @@ pkgbase = mkxp-git
makedepends = vim
depends = ruby
depends = physfs-hg
+ depends = sdl2-hg
depends = sdl2_image
depends = sdl2_ttf
depends = sdl_sound-patched-hg
@@ -22,8 +23,7 @@ pkgbase = mkxp-git
depends = boost-libs
depends = libgl
depends = libsigc++
- depends = fluidsynth
- optdepends = fluidsynth-git: reduced memory footprint for midi playback
+ depends = fluidsynth-git
provides = mkxp
conflicts = mkxp
source = git+https://github.com/Ancurio/mkxp.git
diff --git a/PKGBUILD b/PKGBUILD
index 031eb09720a7..7876bb370375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=mkxp-git
-pkgver=r470.151a1f0
+pkgver=r745.794e86d
pkgrel=1
-pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP (development version)"
+pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP/VX/VX Ace (development version)"
arch=('i686' 'x86_64')
url="https://github.com/Ancurio/mkxp"
license=('GPL2')
-depends=('ruby' 'physfs-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
- 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++' 'fluidsynth')
+depends=('ruby' 'physfs-hg' 'sdl2-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
+ 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++' 'fluidsynth-git')
makedepends=('git' 'boost' 'cmake' 'mesa' 'vim')
conflicts=('mkxp')
provides=('mkxp')
-optdepends=('fluidsynth-git: reduced memory footprint for midi playback')
install=mkxp.install
source=("git+$url.git")
md5sums=('SKIP')
@@ -25,7 +24,12 @@ pkgver() {
build() {
cd mkxp
- cmake ./ -DMRIVERSION=2.1 -DWORKDIR_CURRENT=ON
+ # get the major and minor version of installed ruby, remove any strings (like beta, patchlevel)
+ _rubyver=$(pacman -Q ruby | sed -r 's/^ruby //;s/\.[^\.]+-.+$//;s/[^0-9\.]//')
+ # check for validity, for example rubinius-ruby provides ruby, but cannot be used (no library)
+ [ -z $_rubyver ] && exit 1
+
+ cmake ./ -DMRIVERSION=$_rubyver -DWORKDIR_CURRENT=ON -DSHARED_FLUID=ON
make
}
diff --git a/mkxp.install b/mkxp.install
index 265c7912b578..e76ae16c3867 100644
--- a/mkxp.install
+++ b/mkxp.install
@@ -1,8 +1,8 @@
post_install() {
- echo "To use mkxp, change into the directory of the RPG Maker XP game you want to play"
- echo "and launch 'mkxp'. You may want to add a mkxp.conf to the game directory for"
- echo "customisation, see sample file in '/usr/share/doc/mkxp'."
+ echo "=> To use mkxp, change into the directory of the RPG Maker XP game you want to"
+ echo "=> play and launch 'mkxp'. You may want to add a mkxp.conf to the game directory"
+ echo "=> for customisation, a sample file is provided in '/usr/share/doc/mkxp'."
}
post_upgrade() {