summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-18 11:56:19 +0800
committerzxp198210052024-03-18 11:56:19 +0800
commitde3118aa488b59de1accd280ce7656ddda9f4765 (patch)
tree348c8e0c4886317160202faffdb009cf219a125c
parentd8d893c2db377390434c65bdfff5241cbb9ca085 (diff)
downloadaur-de3118aa488b59de1accd280ce7656ddda9f4765.tar.gz
update to 6.0.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
-rw-r--r--whalebird.sh5
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a2fe989af0d..3935cd0d4d3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = whalebird-bin
pkgdesc = An Electron based Mastodon, Pleroma, and Misskey client
- pkgver = 6.0.4
+ pkgver = 6.0.5
pkgrel = 1
url = https://whalebird.social/
arch = x86_64
license = GPL-3.0-only
depends = electron27
- provides = whalebird=6.0.4
+ provides = whalebird=6.0.5
conflicts = whalebird
- source = whalebird-6.0.4.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v6.0.4/Whalebird-6.0.4-linux-amd64.deb
+ source = whalebird-6.0.5.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v6.0.5/Whalebird-6.0.5-linux-amd64.deb
source = whalebird.sh
- sha256sums = 90b5f5a90f67ed3f9df521e21e470d0222eb0d2104abbe3eb43840b95af150e7
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = 78525f2d659e833ec2d41304891213348ade3a213676585dadfef6877c8d9cf8
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = whalebird-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3a7a14859557..c9ae7a17acda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor : Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
pkgname=whalebird-bin
_pkgname=Whalebird
-pkgver=6.0.4
+pkgver=6.0.5
_electronversion=27
pkgrel=1
pkgdesc="An Electron based Mastodon, Pleroma, and Misskey client"
@@ -21,12 +21,13 @@ source=(
"${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('90b5f5a90f67ed3f9df521e21e470d0222eb0d2104abbe3eb43840b95af150e7'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('78525f2d659e833ec2d41304891213348ade3a213676585dadfef6877c8d9cf8'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/whalebird.sh b/whalebird.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/whalebird.sh
+++ b/whalebird.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file