summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRené Wagner2023-08-05 11:35:30 +0200
committerRené Wagner2023-08-05 11:35:30 +0200
commitde37709122997b297d9005741fe82273ffd58d80 (patch)
treeb6705e1c348e8bc4214ecb250aa0e448731bb955
parent7a7429a531d2873dcb315c23ff44b382f72c32ad (diff)
downloadaur-de37709122997b297d9005741fe82273ffd58d80.tar.gz
update to 0.54
-rw-r--r--.SRCINFO8
-rw-r--r--0001-fix-test-13-when-running-curl-8.2.patch27
-rw-r--r--PKGBUILD12
3 files changed, 41 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 883db38fef32..0f4842b36915 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = perl-net-curl
pkgdesc = Perl interface for libcurl
- pkgver = 0.51
+ pkgver = 0.54
pkgrel = 1
url = http://search.mcpan.org/dist/Net-Curl
arch = i686
@@ -11,7 +11,9 @@ pkgbase = perl-net-curl
depends = curl>=7.37.0
depends = perl
options = !emptydirs
- source = http://search.mcpan.org/CPAN/authors/id/S/SY/SYP/Net-Curl-0.51.tar.gz
- sha256sums = 1e8582d6f1cf1382443765b20976f6e799a2f51eb790c203752be2851682d86c
+ source = http://search.mcpan.org/CPAN/authors/id/S/SY/SYP/Net-Curl-0.54.tar.gz
+ source = 0001-fix-test-13-when-running-curl-8.2.patch
+ sha256sums = ad76bd1bf97d61bbd758a196e945c232d1cb7b2064e751f6c88c344086d6ffbc
+ sha256sums = 1d9f9af639c973f565a2f31d0ba98103a9756b588421da3961921570e57076c9
pkgname = perl-net-curl
diff --git a/0001-fix-test-13-when-running-curl-8.2.patch b/0001-fix-test-13-when-running-curl-8.2.patch
new file mode 100644
index 000000000000..d0a1f6b02092
--- /dev/null
+++ b/0001-fix-test-13-when-running-curl-8.2.patch
@@ -0,0 +1,27 @@
+From fcf332f0c86d2e5646c8aa8a6e44948a0bfb8e1e Mon Sep 17 00:00:00 2001
+Date: Mon, 31 Jul 2023 08:11:38 +0200
+Subject: [PATCH] fix test 13 when running curl>=8.2
+
+---
+ t/old-10errbuf.t | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/t/old-10errbuf.t b/t/old-10errbuf.t
+index b6920ea..4ce5db8 100644
+--- a/t/old-10errbuf.t
++++ b/t/old-10errbuf.t
+@@ -42,6 +42,11 @@ ok( $@, "Non-zero return code indicates the expected failure");
+
+ seek $new_error, 0, 0;
+ my $line = <$new_error>;
++chomp $line;
++if ($line eq "* processing: badprotocol://127.0.0.1:2") {
++ $line = <$new_error>;
++ chomp $line;
++}
+ like( $line, qr/^\*\s+(?:
+ Protocol \s "? badprotocol "? \s not \s supported \s or \s disabled \s in \s libcurl |
+ Unsupported \s protocol: \s badprotocol |
+--
+2.41.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 8b5795265f51..dcd74a83883b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Generator : CPANPLUS::Dist::Arch 1.28
pkgname='perl-net-curl'
-pkgver='0.51'
+pkgver='0.54'
pkgrel='1'
pkgdesc="Perl interface for libcurl"
arch=('i686' 'x86_64')
@@ -12,10 +12,16 @@ options=('!emptydirs')
depends=('curl>=7.37.0' 'perl')
makedepends=('gcc')
url='http://search.mcpan.org/dist/Net-Curl'
-source=("http://search.mcpan.org/CPAN/authors/id/S/SY/SYP/Net-Curl-${pkgver}.tar.gz")
-sha256sums=('1e8582d6f1cf1382443765b20976f6e799a2f51eb790c203752be2851682d86c')
+source=("http://search.mcpan.org/CPAN/authors/id/S/SY/SYP/Net-Curl-${pkgver}.tar.gz" "0001-fix-test-13-when-running-curl-8.2.patch")
+sha256sums=('ad76bd1bf97d61bbd758a196e945c232d1cb7b2064e751f6c88c344086d6ffbc'
+ '1d9f9af639c973f565a2f31d0ba98103a9756b588421da3961921570e57076c9')
_distdir="Net-Curl-${pkgver}"
+prepare() {
+ cd "$srcdir/$_distdir"
+ patch --strip=1 --input="$srcdir/0001-fix-test-13-when-running-curl-8.2.patch"
+}
+
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
PERL_AUTOINSTALL=--skipdeps \