summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibault Boyeux2021-04-24 13:23:30 +0000
committerThibault Boyeux2021-04-24 13:23:30 +0000
commitde3fd554eedd33ab5762b711d79ef651a3445ddc (patch)
tree77e32dfde6e9b218a74411bb4aa64e94ba83015d
parent383ff7a311f66ffd82aac85b70931c89b46d24a6 (diff)
downloadaur-de3fd554eedd33ab5762b711d79ef651a3445ddc.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7181dc0aa7c3..9cb8f0060aca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlite-fts3-parenthesis
pkgdesc = A C library that implements an SQL database engine. Compiled with 'SQLITE_ENABLE_FTS3_PARENTHESIS' option to allow operators AND and NOT and nested parenthesis in queries.
- pkgver = 3.34.1
+ pkgver = 3.35.5
pkgrel = 1
url = https://www.sqlite.org/
arch = x86_64
@@ -8,13 +8,13 @@ pkgbase = sqlite-fts3-parenthesis
makedepends = tcl
depends = readline
depends = zlib
- provides = sqlite=3.34.1
+ provides = sqlite=3.35.5
conflicts = sqlite
replaces = sqlite3
options = !emptydirs
options = !makeflags
- source = https://www.sqlite.org/2021/sqlite-src-3340100.zip
- sha256sums = dddd237996b096dee8b37146c7a37a626a80306d6695103d2ec16ee3b852ff49
+ source = https://www.sqlite.org/2021/sqlite-src-3350500.zip
+ sha256sums = f4beeca5595c33ab5031a920d9c9fd65fe693bad2b16320c3a6a6950e66d3b11
pkgname = sqlite-fts3-parenthesis
diff --git a/PKGBUILD b/PKGBUILD
index 3bbd310546fe..4ca206d8d98a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=('sqlite-fts3-parenthesis')
-_srcver=3340100
+_srcver=3350500
_docver=${_srcver}
-pkgver=3.34.1
+pkgver=3.35.5
pkgrel=1
pkgdesc="A C library that implements an SQL database engine. Compiled with 'SQLITE_ENABLE_FTS3_PARENTHESIS' option to allow operators AND and NOT and nested parenthesis in queries."
arch=('x86_64')
@@ -19,7 +19,7 @@ replaces=("sqlite3")
source=(https://www.sqlite.org/2021/sqlite-src-${_srcver}.zip)
options=('!emptydirs' '!makeflags') # json extensions breaks parallel build
# upstream now switched to sha3sums - currently not supported by makepkg
-sha256sums=('dddd237996b096dee8b37146c7a37a626a80306d6695103d2ec16ee3b852ff49')
+sha256sums=('f4beeca5595c33ab5031a920d9c9fd65fe693bad2b16320c3a6a6950e66d3b11')
package() {
cd sqlite-src-$_srcver
@@ -46,18 +46,20 @@ prepare() {
# https://src.fedoraproject.org/rpms/sqlite/blob/master/f/sqlite.spec
# patch -Np1 -i ../sqlite-lemon-system-template.patch
-# autoreconf -vfi
+ #autoreconf -vfi
}
build() {
- export CPPFLAGS="$CPPFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 \
- -DSQLITE_ENABLE_UNLOCK_NOTIFY \
- -DSQLITE_ENABLE_DBSTAT_VTAB=1 \
- -DSQLITE_ENABLE_FTS3_TOKENIZER=1 \
- -DSQLITE_ENABLE_FTS3_PARENTHESIS \
- -DSQLITE_SECURE_DELETE \
- -DSQLITE_MAX_VARIABLE_NUMBER=250000 \
- -DSQLITE_MAX_EXPR_DEPTH=10000"
+ export CPPFLAGS="$CPPFLAGS \
+ -DSQLITE_ENABLE_COLUMN_METADATA=1 \
+ -DSQLITE_ENABLE_UNLOCK_NOTIFY \
+ -DSQLITE_ENABLE_DBSTAT_VTAB=1 \
+ -DSQLITE_ENABLE_FTS3_TOKENIZER=1 \
+ -DSQLITE_ENABLE_FTS3_PARENTHESIS \
+ -DSQLITE_SECURE_DELETE \
+ -DSQLITE_ENABLE_STMTVTAB \
+ -DSQLITE_MAX_VARIABLE_NUMBER=250000 \
+ -DSQLITE_MAX_EXPR_DEPTH=10000"
# build sqlite
cd sqlite-src-$_srcver