aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryar2017-07-01 23:16:02 -0700
committeryar2017-07-01 23:16:02 -0700
commitde5eb511e9c9104a808309c694ccdcafd09b62da (patch)
treefed9416c9060f4bee8e4a15b2dcb796b4b778d9f
parent0e4d1d5ff807848be9b6522b36acb42b72c88eec (diff)
downloadaur-de5eb511e9c9104a808309c694ccdcafd09b62da.tar.gz
march/mtune stuff in readme is obsolete (for now?)
-rw-r--r--PKGBUILD2
-rw-r--r--README.md11
2 files changed, 0 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 074b86bb9dd8..ec76d2568994 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -76,8 +76,6 @@ prepare() {
build() {
cd "${srcdir}/${_srcname}"
-# CFLAGS=${CFLAGS}" -march=sandybridge -mtune=sandybridge "
-# CXXFLAGS=${CXXFLAGS}" -march=sandybridge -mtune=sandybridge "
[[ "$MAKEFLAGS" =~ -j[0-9]* ]] || MAKEFLAGS+=" -j$(nproc)"
ionice -c 3 nice -n 16 make ${MAKEFLAGS} LOCALVERSION= bzImage modules
}
diff --git a/README.md b/README.md
index 2449d3b2e3a8..1327b2e4228a 100644
--- a/README.md
+++ b/README.md
@@ -32,17 +32,6 @@ Configs are a compromise between vanilla Linode and Arch. Most drivers are disab
Take extra care to make sure you're booting from the correct device name. Xen devices are called /dev/xvda while KVM devices are called /dev/sda. If you're running grub inside your old Xen linode, it will automatically add "root=/dev/xvda" to your kernel line in /boot/grub/grub.cfg. Once you migrate to KVM, this will no longer work. You'll have to either edit this file by hand before shutting down to migrate, or edit it using the interactive grub command line afterwards. Once you've migrated, running grub-mkconfig again should fix it. Also be sure to check /etc/fstab or /etc/crypttab for any other device names that might give you boot problems.
-# CPU ARCHITECTURE
-
-By default, the kernel is compiled with `-march=sandybridge -mtune=sandybridge`. This seems to be most common in my (limited) experience, but some linodes may have haswell, corei7 or other CPUs, in which case you can edit CFLAGS and CXXFLAGS in the PKGBUILD. To find yours:
-
-```
-$ gcc -c -Q -march=native --help=target 2>&1 | grep -e march -e mtune
--march= sandybridge
--mtune-ctrl=
--mtune= sandybridge
-```
-
# STEPS TO USE
1. pacman -Syu