summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2023-06-09 11:00:08 +1000
committerRod Kay2023-06-09 11:00:08 +1000
commitdebddaed7ec987cebf14d972986700062e86f9ac (patch)
tree23a20c3b05313137258b9714923fc7237e4dc150
parent8106eb1f5be36d4dae234904e9d28cf483e70142 (diff)
downloadaur-debddaed7ec987cebf14d972986700062e86f9ac.tar.gz
Update to version '24.0w'.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD45
2 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d98bdba4e57..a9efd6e5a7c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = gnatcoll-gnatinspect
pkgdesc = GNAT Components Collection - the gnatinspect tool.
- pkgver = 23.0.0
+ pkgver = 24.0w
pkgrel = 1
epoch = 1
- url = https://github.com/AdaCore/gnatcoll-db/
+ url = https://github.com/AdaCore/gnatcoll-db
arch = i686
arch = x86_64
license = GPL3
@@ -11,7 +11,7 @@ pkgbase = gnatcoll-gnatinspect
makedepends = gprbuild
depends = gnatcoll-readline
depends = gnatcoll-xref
- source = gnatcoll-db-23.0.0.tar.gz::https://github.com/AdaCore/gnatcoll-db//archive/v23.0.0.tar.gz
- sha256sums = 0a4cc9f9c034be34ca4d08ae2c8fedce66c462719a2e1035d916559f6eee7a4d
+ source = file:///opt/gnatstudio-sources/gnatcoll-db-24.0w-20230324-166CC-src.tar.gz
+ sha256sums = 374adf9064cbdf87c4c3f4cc815d8c0f914820a0caa45edd605545ee7a4c07c2
pkgname = gnatcoll-gnatinspect
diff --git a/PKGBUILD b/PKGBUILD
index 6827fe08aa2e..d853ddf2c436 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
# Maintainer: xiretza <xiretza+aur@gmail.com>
# Maintainer: Rod Kay <rodakay5 at gmail dot com>
-pkgname=gnatcoll-gnatinspect
epoch=1
-pkgver=23.0.0
-pkgrel=1
-_repo_name=gnatcoll-db
+pkgname=gnatcoll-gnatinspect
+pkgver=24.0w
+pkgrel=1
pkgdesc='GNAT Components Collection - the gnatinspect tool.'
-url='https://github.com/AdaCore/gnatcoll-db/'
-arch=('i686' 'x86_64')
-license=('GPL3' 'custom')
-depends=('gnatcoll-readline' 'gnatcoll-xref')
-makedepends=('gprbuild')
+url=https://github.com/AdaCore/gnatcoll-db
+arch=(i686 x86_64)
+license=(GPL3 custom)
+
+depends=(gnatcoll-readline gnatcoll-xref)
+makedepends=(gprbuild)
+
+_repo_name=gnatcoll-db
+_source_dir=$_repo_name-$pkgver-20230428-1640B-src
+
+source=(file:///opt/gnatstudio-sources/$_repo_name-$pkgver-20230324-166CC-src.tar.gz)
+sha256sums=(374adf9064cbdf87c4c3f4cc815d8c0f914820a0caa45edd605545ee7a4c07c2)
-source=("$_repo_name-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('0a4cc9f9c034be34ca4d08ae2c8fedce66c462719a2e1035d916559f6eee7a4d')
build()
{
- cd "$srcdir/$_repo_name-$pkgver/gnatinspect"
+ cd $srcdir/$_source_dir/gnatinspect
# Rid flags not used by Ada.
+ #
CFLAGS="${CFLAGS//-Wformat}"
CFLAGS="${CFLAGS//-Werror=format-security}"
@@ -30,21 +35,25 @@ build()
make -j1 GPRBUILD_OPTIONS="-R -cargs $CFLAGS -largs $LDFLAGS -gargs"
}
+
package()
{
- cd "$srcdir/$_repo_name-$pkgver/gnatinspect"
+ cd $srcdir/$_source_dir/gnatinspect
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
+ #
make prefix="$pkgdir/usr" install -j1
# Install the license.
+ #
install -D -m644 \
- "../COPYING3" \
- "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+ ../COPYING3 \
+ $pkgdir/usr/share/licenses/$pkgname/COPYING3
# Install the custom license.
+ #
install -D -m644 \
- "../COPYING.RUNTIME" \
- "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
-}
+ ../COPYING.RUNTIME \
+ $pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME
+} \ No newline at end of file