summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Bunkus2015-06-13 12:53:19 +0200
committerMoritz Bunkus2015-06-13 12:53:19 +0200
commitdec8b6210919742ce1a44e6ea1a8a8e49f32b354 (patch)
tree350a6ad61fecb81ea710c15e961d78fa1549a215
downloadaur-dec8b6210919742ce1a44e6ea1a8a8e49f32b354.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
3 files changed, 89 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..42b1a262de77
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-file-flock
+ pkgdesc = file locking with flock
+ pkgver = 2014.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/File-Flock
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ makedepends = perl-file-slurp
+ makedepends = perl-test-sharedfork
+ depends = perl-anyevent
+ depends = perl-data-structure-util
+ depends = perl-io-event>=0.812
+ source = http://cpan.metacpan.org/authors/id/M/MU/MUIR/modules/File-Flock-2014.01.tar.gz
+ options = !emptydirs
+
+pkgname = perl-file-flock
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d96be38f529d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = perl-file-flock
+ pkgdesc = file locking with flock
+ pkgver = 2014.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/File-Flock
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ makedepends = perl-file-slurp
+ makedepends = perl-test-sharedfork
+ depends = perl-anyevent
+ depends = perl-data-structure-util
+ depends = perl-io-event>=0.812
+ options = !emptydirs
+ source = http://cpan.metacpan.org/authors/id/M/MU/MUIR/modules/File-Flock-2014.01.tar.gz
+ md5sums = 12a3342c96c5e42f1b7c7ec737327199
+ sha512sums = 3892d9c126c809709e690391396bc349b95b790b2d1be34bf1d24d728dbbe8b9e5dc7a35f5bf17b420b5912aa6b1e2ef1aa6c6b60b48c4e17685eade7b3fae16
+
+pkgname = perl-file-flock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f81b8ffbd96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Moritz Bunkus <moritz@bunkus.org>
+
+pkgname=perl-file-flock
+pkgver='2014.01'
+pkgrel='1'
+pkgdesc="file locking with flock"
+arch=('any')
+url="http://search.cpan.org/dist/File-Flock"
+license=('GPL' 'PerlArtistic')
+depends=('perl-anyevent' 'perl-data-structure-util' 'perl-io-event>=0.812')
+makedepends=('perl-file-slurp' 'perl-test-sharedfork')
+options=('!emptydirs')
+source=("http://cpan.metacpan.org/authors/id/M/MU/MUIR/modules/File-Flock-${pkgver}.tar.gz")
+md5sums=('12a3342c96c5e42f1b7c7ec737327199')
+sha512sums=('3892d9c126c809709e690391396bc349b95b790b2d1be34bf1d24d728dbbe8b9e5dc7a35f5bf17b420b5912aa6b1e2ef1aa6c6b60b48c4e17685eade7b3fae16')
+
+prepare_environment() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ cd "${srcdir}/File-Flock-${pkgver}"
+}
+
+build() {
+ prepare_environment
+ # Fix bad file permissions in the tar ball
+ chmod -R u+rw .
+
+ # Build normally
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepare_environment
+ make test
+}
+
+package() {
+ prepare_environment
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: