summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-04 23:29:54 -0400
committerKyle Keen2015-08-04 23:29:54 -0400
commitdf1d419e2f381b0e215af14bc865ecf0cd892c6e (patch)
treeb225208312d6abc90f16dcc4cdba1f7d658692fb
downloadaur-df1d419e2f381b0e215af14bc865ecf0cd892c6e.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD46
-rw-r--r--p910nd.conf1
-rw-r--r--p910nd.service11
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b6edc43fb0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = p910nd
+ pkgdesc = A small printer daemon intended for diskless workstations that passes jobs directly to the printer
+ pkgver = 0.97
+ pkgrel = 1
+ url = http://p910nd.sourceforge.net
+ arch = i686
+ arch = x86_64
+ arch = armv5
+ arch = armv5h
+ arch = armv6
+ arch = armv6h
+ arch = armv7
+ arch = armv7h
+ license = GPL2
+ depends = glibc
+ backup = etc/conf.d/p910nd
+ source = http://downloads.sf.net/p910nd/p910nd-0.97.tar.bz2
+ source = p910nd.service
+ source = p910nd.conf
+ md5sums = 69461a6c54dca0b13ecad5b83864b43e
+ md5sums = e37030a69b7bf302cfb23d88e25ebbdf
+ md5sums = ea1db6d612058532c525efedd54990f2
+
+pkgname = p910nd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0534bca012cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: Danilo Luvizotto <danilo.luvizotto@gmail.com>
+# Contributor: Wieland Hoffmann <the_mineo@web.de>
+# Contributor: G_Syme <demichan(at)mail(dot)upb(dot)de>
+pkgname=p910nd
+pkgver=0.97
+pkgrel=1
+pkgdesc="A small printer daemon intended for diskless workstations that passes jobs directly to the printer"
+arch=('i686' 'x86_64' 'armv5' 'armv5h' 'armv6' 'armv6h' 'armv7' 'armv7h')
+url="http://p910nd.sourceforge.net"
+license=('GPL2')
+depends=('glibc')
+backup=('etc/conf.d/p910nd')
+#options=('emptydirs')
+source=(http://downloads.sf.net/$pkgname/$pkgname-$pkgver.tar.bz2 \
+ $pkgname.service \
+ $pkgname.conf)
+md5sums=('69461a6c54dca0b13ecad5b83864b43e'
+ 'e37030a69b7bf302cfb23d88e25ebbdf'
+ 'ea1db6d612058532c525efedd54990f2')
+
+CONFIGDIR=/etc/conf.d
+INITSCRIPT=""
+SCRIPTDIR=""
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # TODO: this should be in its own subdir, but needs to be created at boot
+ sed -i "s|/var/lock/subsys|/run/lock|" $pkgname.c
+ # modern linux FSH
+ sed -i 's|sbin|bin|' *
+ sed -i 's|var/lock|run/lock|' *
+ sed -i 's|var/run|run|' *
+ sed -i 's|$(INSTALL) $(INITSCRIPT) $(DESTDIR)$(SCRIPTDIR)/$(PROG)||' Makefile
+ make CONFIGDIR=$CONFIGDIR INITSCRIPT=$INITSCRIPT SCRIPTDIR=$SCRIPTDIR
+ sed -i 's|P910ND_OPTS=""|P910ND_OPTS="-f /dev/usb/lp0"|' $pkgname.conf
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make CONFIGDIR=$CONFIGDIR INITSCRIPT=$INITSCRIPT SCRIPTDIR=$SCRIPTDIR DESTDIR="$pkgdir" install
+ #install -dm755 "$pkgdir/run/lock/$pkgname"
+ install -Dm644 "$srcdir/$pkgname.service" "$pkgdir/usr/lib/systemd/system/$pkgname.service"
+ install -Dm644 "$srcdir/$pkgname.conf" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+}
+
diff --git a/p910nd.conf b/p910nd.conf
new file mode 100644
index 000000000000..23b29c6a37f8
--- /dev/null
+++ b/p910nd.conf
@@ -0,0 +1 @@
+d /run/lock/p910nd 0755 root root -
diff --git a/p910nd.service b/p910nd.service
new file mode 100644
index 000000000000..2a899940cd72
--- /dev/null
+++ b/p910nd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A small printer daemon intended for diskless workstations that passes jobs directly to the printer
+After=network.target
+
+[Service]
+Type=forking
+EnvironmentFile=/etc/conf.d/p910nd
+ExecStart=/usr/bin/p910nd $P910ND_OPTS $P910ND_NUM
+
+[Install]
+WantedBy=multi-user.target