summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 19:57:55 -0700
committerGI_Jack2023-05-13 19:57:55 -0700
commitdf2335e683d1a2998dfca921c6094431f5aa4fc7 (patch)
treeddfb4fa0eb8993983e1f49c1c2d56c7d860dfde6
parent4ec93728f4fb2ba6beb927cd4e6fcfb4ab116c61 (diff)
downloadaur-df2335e683d1a2998dfca921c6094431f5aa4fc7.tar.gz
version 0.1.47
updated for modern packaging standards
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4e502176624..c2d8951c2be4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
# Generated by mksrcinfo(replacement shim) v8
-# Wed Dec 15 01:52:06 PM PST 2021
+# Sat May 13 07:57:49 PM PDT 2023
pkgbase = python-blue-loader
pkgdesc = Python tools to communicate with Ledger Blue, Nano S and Nano X
- pkgver = 0.1.41
+ pkgver = 0.1.47
pkgrel = 1
url = https://github.com/LedgerHQ/blue-loader-python
arch = any
license = Apache
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-hidapi
depends = python-protobuf
@@ -18,7 +20,7 @@ pkgbase = python-blue-loader
depends = python-u2flib-host
depends = python-ecpy
optdepends = python-pyscard: smartcard
- source = python-blue-loader-0.1.41.tar.gz::https://github.com/LedgerHQ/blue-loader-python/archive/0.1.41.tar.gz
- sha256sums = 11ec087dacaea54415760b26839fc38d4f972477fd82ecdee45635a580e8b56a
+ source = python-blue-loader-0.1.47.tar.gz::https://github.com/LedgerHQ/blue-loader-python/archive/0.1.47.tar.gz
+ sha256sums = 72b89018b81675a49323e97663928dffd5ce133dc2ae2a1e888100e2bb2b318d
pkgname = python-blue-loader
diff --git a/PKGBUILD b/PKGBUILD
index 66a21d06a7f0..0af8d1191d5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: GI Jack <gi_jack@hackermail.com>
pkgname=python-blue-loader
-pkgver=0.1.41
+pkgver=0.1.47
pkgrel=1
pkgdesc="Python tools to communicate with Ledger Blue, Nano S and Nano X"
arch=('any')
@@ -11,20 +11,17 @@ license=('Apache')
depends=('python' 'python-hidapi' 'python-protobuf' 'python-pycryptodomex'
'python-future' 'python-pillow' 'python-websocket-client' 'python-u2flib-host'
'python-ecpy')
-makedepends=('python-setuptools')
-checkdepends=()
+makedepends=('python-build' 'python-installer' 'python-wheel')
optdepends=('python-pyscard: smartcard')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/LedgerHQ/blue-loader-python/archive/${pkgver}.tar.gz")
-sha256sums=('11ec087dacaea54415760b26839fc38d4f972477fd82ecdee45635a580e8b56a')
+sha256sums=('72b89018b81675a49323e97663928dffd5ce133dc2ae2a1e888100e2bb2b318d')
+
+build() {
+ cd "blue-loader-python-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
- cd blue-loader-python-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "blue-loader-python-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}