summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0k3r2014-02-07 20:01:46 +0100
committerJ0k3r2014-02-07 20:58:56 +0100
commitdf384dc224c65392b8590d48b424b8fe3ba91eae (patch)
tree362f4fefdafb72f0ee16174d98b5c140d61ec0c3
downloadaur-df384dc224c65392b8590d48b424b8fe3ba91eae.tar.gz
AUR4 split: Initial Commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD77
-rw-r--r--hotlinemiami.desktop9
-rw-r--r--hotlinemiami.pngbin0 -> 877 bytes
5 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c660a04d6e68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = hotlinemiami
+ pkgdesc = A 2D top-down action video game
+ pkgver = 1.0.9a
+ pkgrel = 2
+ url = http://hotlinemiami.com/
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = unknown
+ depends = openal
+ depends = libvorbis
+ depends = nvidia-cg-toolkit
+ depends = glu
+ depends = fontconfig
+ depends = lib32-xrandr
+ depends = libxrandr
+ depends = qt5-base
+ noextract = hotlinemiami_v1.0.9a-Linux_28-05-2013.tar.gz
+ source = hib://hotlinemiami_v1.0.9a-Linux_28-05-2013.tar.gz
+ source = hotlinemiami.desktop
+ source = hotlinemiami.png
+ sha256sums = 070300558ba52f75455d1645bba6dd956f460ada0d3839f8b3c3ac712ba957da
+ sha256sums = ca65c11bc9e06f438b2da2bb44c40424537e60b704656a155f672b16fde5f8de
+ sha256sums = 01432c725bd258761e67fe1db94531465ba0480e250724cf6b939669e13b0e8a
+
+pkgname = hotlinemiami
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8e053597b40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.*
+*.src.*
+[Hh]otline[Mm]iami_*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50c246b474ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: J0k3r <moebius282 e4at gmail D0_T com>
+
+pkgname=hotlinemiami
+pkgver=1.0.9a
+pkgrel=2
+pkgdesc="A 2D top-down action video game"
+url="http://hotlinemiami.com/"
+license=('unknown')
+# © Dennaton Interactive Design of the Future ™
+arch=('i686' 'x86_64')
+groups=("games")
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-openal' 'lib32-libvorbis' 'lib32-nvidia-cg-toolkit' 'lib32-glu' 'lib32-fontconfig' 'lib32-libxrandr')
+else
+ depends=('openal' 'libvorbis' 'nvidia-cg-toolkit' 'glu' 'fontconfig' 'lib32-xrandr' 'libxrandr' 'qt5-base' )
+fi
+_archivename="${pkgname}_v${pkgver}-Linux_28-05-2013"
+source=("hib://${_archivename}.tar.gz"
+ "${pkgname}.desktop"
+ "${pkgname}.png")
+sha256sums=('070300558ba52f75455d1645bba6dd956f460ada0d3839f8b3c3ac712ba957da'
+ 'ca65c11bc9e06f438b2da2bb44c40424537e60b704656a155f672b16fde5f8de'
+ '01432c725bd258761e67fe1db94531465ba0480e250724cf6b939669e13b0e8a')
+noextract=("${source[0]:6}")
+PKGEXT=".pkg.tar"
+
+
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, to use hib-dlagent to download files set something like this in
+# your makepkg.conf (change/add -k and add -u/-p to your needs):
+# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+#
+# To auto-search through a directory containing Humble Bundle downloads, you
+# could set:
+# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+
+package()
+{
+ install -d "${pkgdir}/opt/${pkgname}/"
+
+# Otherwise it extract the files loosely in $srcdir
+ tar -xzf "${srcdir}/${_archivename}.tar.gz" -C "${pkgdir}/opt/${pkgname}/"
+
+# We don't need these, as we use the shared system libraries
+# We can't go this simple way on x86_64 currently, as arch doesn't provide lib32-qt5 :(
+ if [ "$CARCH" = "x86_64" ]; then
+ _purgelibs=('libopenal.so.1' 'libCgGL.so' 'libCg.so')
+ for i in "${_purgelibs[@]}"; do
+ rm "${pkgdir}/opt/${pkgname}/lib/${i}"
+ done
+ chown root:root "${pkgdir}/opt/${pkgname}/lib/"
+ else
+ rm -r "${pkgdir}/opt/${pkgname}/lib/"
+ fi
+
+ find "${pkgdir}/opt/${pkgname}/" -type f -exec chown root:root "{}" \;
+
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+# I extracted this from the windows executable; couldn't find one anywhere else
+ install -D -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ install -d "${pkgdir}/usr/bin/"
+
+# We need this as the program expect to be launched from the same directory it resides in
+ cat > "${pkgdir}/usr/bin/${pkgname}" <<-EOF
+ #!/bin/bash
+
+ cd "/opt/${pkgname}/"
+ exec ./hotline_launcher
+ EOF
+
+ chmod 0755 "${pkgdir}/usr/bin/${pkgname}"
+} \ No newline at end of file
diff --git a/hotlinemiami.desktop b/hotlinemiami.desktop
new file mode 100644
index 000000000000..513df0e83cbd
--- /dev/null
+++ b/hotlinemiami.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Hotline Miami
+Comment=A 2D top-down action video game
+Icon=hotlinemiami.png
+Exec=hotlinemiami
+Categories=Game; \ No newline at end of file
diff --git a/hotlinemiami.png b/hotlinemiami.png
new file mode 100644
index 000000000000..677ec3817c46
--- /dev/null
+++ b/hotlinemiami.png
Binary files differ