summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-09-22 16:56:08 +0200
committerwillemw122023-09-22 16:56:08 +0200
commitdf64ec7e59e92364d1279c0b84cf62a75301be9b (patch)
treed56c4f4a47607e092396ab0f872187e6a9607516
parent46bb3e648c6e7487369889d0199d41b27ffb228c (diff)
downloadaur-df64ec7e59e92364d1279c0b84cf62a75301be9b.tar.gz
Update to standards based install
Add git clean.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4652a15ac5e1..62612488fdfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,9 @@ pkgbase = podfox-git
arch = any
license = GPL3
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python-colorama
depends = python-docopt
diff --git a/PKGBUILD b/PKGBUILD
index 72189f7a6cc0..9f02a135483b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=podfox-git
pkgver=r92.0ec75cb
pkgrel=1
-pkgdesc="Catch and manage podcasts from the terminal"
-arch=('any')
-url="https://github.com/brtmr/podfox"
-license=('GPL3')
-makedepends=('git' 'python-setuptools')
-depends=('python-colorama' 'python-docopt' 'python-feedparser' 'python-pycurl' 'python-requests')
+pkgdesc='Catch and manage podcasts from the terminal'
+arch=(any)
+url=https://github.com/brtmr/podfox
+license=(GPL3)
+makedepends=(git python-build python-installer python-wheel python-setuptools)
+depends=(python-colorama python-docopt python-feedparser python-pycurl python-requests)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
@@ -20,18 +20,18 @@ pkgver() {
}
prepare() {
- cd $pkgname
+ git -C $pkgname clean -dfx
+
# Patch: add "global CONFIGURATION" statement
- sed -i 's|\(^[ \t]*\)\([^ ]*\)\( = json.load\)|\1global \2\n\1\2\3|' podfox/__init__.py
+ sed -i 's|\(^[ \t]*\)\([^ ]*\)\( = json.load\)|\1global \2\n\1\2\3|' $pkgname/podfox/__init__.py
}
build() {
cd $pkgname
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-