summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-30 08:21:37 +0400
committerAnton Leontiev2015-02-15 07:48:18 +0300
commitdf670b2a6103cb86f246cc24671f048dd71cdffc (patch)
tree6f34b7b1570f53e3f496bc630a9cfad3fe5e227e
parent471f3a72f98e858067bf7008fee537dd384c4745 (diff)
downloadaur-df670b2a6103cb86f246cc24671f048dd71cdffc.tar.gz
Updated to v5.8.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6efc8cf4cee7..1dc8a03e8678 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = numdiff
pkgdesc = Program to compare files ignoring small numeric differences
- pkgver = 5.6.1
+ pkgver = 5.8.0
pkgrel = 1
url = http://www.nongnu.org/numdiff/
install = numdiff.install
@@ -9,8 +9,9 @@ pkgbase = numdiff
license = GPL3
makedepends = gmp
depends = gmp
- source = http://savannah.nongnu.org/download/numdiff/numdiff-5.6.1.tar.gz
- md5sums = 96b5cae2e6a50a3fd23f1cd9b15798fd
+ options = !buildflags
+ source = http://savannah.nongnu.org/download/numdiff/numdiff-5.8.0.tar.gz
+ md5sums = 1e0a88b5422fd56caa79b301abaad1f2
pkgname = numdiff
diff --git a/PKGBUILD b/PKGBUILD
index 0740ed17fdfb..7811c42bdb8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
pkgname=numdiff
-pkgver=5.6.1
+pkgver=5.8.0
pkgrel=1
arch=('i686' 'x86_64')
-pkgdesc="Program to compare files ignoring small numeric differences"
-url="http://www.nongnu.org/numdiff/"
+pkgdesc='Program to compare files ignoring small numeric differences'
+url='http://www.nongnu.org/numdiff/'
license=('GPL3')
makedepends=('gmp')
depends=('gmp')
source=(http://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz)
install=numdiff.install
-md5sums=('96b5cae2e6a50a3fd23f1cd9b15798fd')
+md5sums=('1e0a88b5422fd56caa79b301abaad1f2')
+options=(!buildflags)
+
+# Don't allow '--enable-optimization' or '-O' in CFLAGS.
+# See 'Known issues' on the site
+# The bug reproduces on GCC 4.8.1 x86_64
build() {
- cd $srcdir/$pkgname-$pkgver
-
- # unset MAKEFLAGS
- ./configure --prefix=/usr --enable-optimization --enable-nls --enable-gmp
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --enable-nls --enable-gmp
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
- make DESTDIR=$pkgdir install
- make DESTDIR=$pkgdir install-nls
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-nls
# We delete info file because there is already gzipped one
- rm $pkgdir/usr/share/info/$pkgname.info
+ rm "$pkgdir/usr/share/info/$pkgname.info"
}