summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorttzhou2015-07-01 16:54:38 -0400
committerttzhou2015-07-01 16:54:38 -0400
commitdf910345f4e22b46626427d6e32634e49406e002 (patch)
treed187410e8a43819961c8b4841674755688496e5b
downloadaur-df910345f4e22b46626427d6e32634e49406e002.tar.gz
Initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
-rw-r--r--setroot.install11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35b94c5b80a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 4.2.1
+# Thu May 14 03:59:35 UTC 2015
+pkgbase = setroot
+ pkgdesc = simple program that sets your (X11) wallpaper. inspired by the *setroots and feh.
+ pkgver = v1.4.4
+ pkgrel = 1
+ url = https://github.com/ttzhou/setroot
+ install = setroot.install
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ makedepends = pkg-config
+ depends = imlib2
+ depends = libx11
+ optdepends = sxiv: use its image viewer along with key-handler to call setroot
+ optdepends = libxinerama: for multiple monitors
+ provides = setroot
+ conflicts = setroot
+ source = git+https://github.com/ttzhou/setroot.git#tag=v1.4.4
+ md5sums = SKIP
+
+pkgname = setroot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..718f66d84e19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Tim Zhou <ttzhou@uwaterloo.ca>
+# Author: ttz <ttzhou@uwaterloo.ca>
+
+_pkgname=setroot
+pkgname=setroot
+pkgver=v1.4.4
+pkgrel=1
+pkgdesc="simple program that sets your (X11) wallpaper. inspired by the *setroots and feh."
+arch=('i686' 'x86_64')
+url="https://github.com/ttzhou/setroot"
+license=('GPLv3')
+depends=('imlib2' 'libx11')
+makedepends=('git' 'pkg-config')
+optdepends=('sxiv: use its image viewer along with key-handler to call setroot'
+ 'libxinerama: for multiple monitors')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/ttzhou/${_pkgname}.git#tag=${pkgver}")
+install=setroot.install
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo $(git describe)
+}
+
+build() {
+ cd $_pkgname
+ make xinerama=$(pkg-config --exists xinerama && echo 1)
+}
+
+package() {
+ cd $_pkgname
+ make PREFIX="usr" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/setroot.install b/setroot.install
new file mode 100644
index 000000000000..0f541d29dc83
--- /dev/null
+++ b/setroot.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "Configuration directory \"\${XDG_CONFIG_HOME:-\$HOME/.config}/setroot\" will be created upon first invocation of \"setroot --store <opts>\"."
+}
+
+post_upgrade() {
+ post_install;
+}
+
+post_remove() {
+ echo "Configuration directory \"\${XDG_CONFIG_HOME:-\$HOME/.config}/setroot\" will need to be manually removed."
+}