summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2022-03-14 17:10:19 +0100
committerAndrea Feletto2022-03-14 17:10:19 +0100
commitdf9181f512dbef616285d34b563ce8253ade81a8 (patch)
tree50e7e4c31498454282d11a030671e427922941f3
parent070a0634091187b2b83cf5bbc4e0ba0ff28dd587 (diff)
downloadaur-df9181f512dbef616285d34b563ce8253ade81a8.tar.gz
add service and sysusers files
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--gmid.conf1
-rwxr-xr-xgmid.service22
4 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84d289452c21..9b09491027d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gmid-bin
pkgdesc = Fast Gemini server written with security in mind.
pkgver = 1.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://gmid.omarpolo.com
arch = x86_64
license = ISC
@@ -10,6 +10,10 @@ pkgbase = gmid-bin
conflicts = gmid
conflicts = gmid-git
source = https://github.com/omar-polo/gmid/releases/download/1.8.1/gmid-1.8.1-binaries.tar.gz
+ source = gmid.service
+ source = gmid.conf
sha256sums = 7983a89f427bbdfb00ea118ff0471d8291afaa370814d7a93d6be294644592f7
+ sha256sums = 61450ba6fb7283b03f099e5172cf4e64bf40093ad2bd126b7915940d40922c9a
+ sha256sums = 4d943727a57dbf5f246963c0f90ccc54919cc2296538457e6b16f29f7580d9d6
pkgname = gmid-bin
diff --git a/PKGBUILD b/PKGBUILD
index c71aa36e0abd..818fb7f2557a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gmid-bin
_pkgname=${pkgname%-*}
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
pkgdesc='Fast Gemini server written with security in mind.'
arch=('x86_64')
url='https://gmid.omarpolo.com'
@@ -12,10 +12,22 @@ license=('ISC')
provides=('gmid')
conflicts=('gmid' 'gmid-git')
depends=('libretls')
-source=("https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver-binaries.tar.gz")
-sha256sums=('7983a89f427bbdfb00ea118ff0471d8291afaa370814d7a93d6be294644592f7')
+source=(
+ "https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver-binaries.tar.gz"
+ 'gmid.service'
+ 'gmid.conf'
+)
+sha256sums=(
+ '7983a89f427bbdfb00ea118ff0471d8291afaa370814d7a93d6be294644592f7'
+ '61450ba6fb7283b03f099e5172cf4e64bf40093ad2bd126b7915940d40922c9a'
+ '4d943727a57dbf5f246963c0f90ccc54919cc2296538457e6b16f29f7580d9d6'
+)
package() {
+ cd "$srcdir"
+ install -Dm644 gmid.service -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 gmid.conf -t "$pkgdir/usr/lib/sysusers.d"
+
cd "$srcdir/$_pkgname-$pkgver-binaries"
install -Dm755 "gmid.linux.amd64" "$pkgdir/usr/bin/gmid"
install -Dm755 "gg.linux.amd64" "$pkgdir/usr/bin/gg"
diff --git a/gmid.conf b/gmid.conf
new file mode 100644
index 000000000000..fb0a75827da9
--- /dev/null
+++ b/gmid.conf
@@ -0,0 +1 @@
+u gmid - "gmid Gemini server" - - \ No newline at end of file
diff --git a/gmid.service b/gmid.service
new file mode 100755
index 000000000000..0cb2bd506efd
--- /dev/null
+++ b/gmid.service
@@ -0,0 +1,22 @@
+[Unit]
+Description=The gmid Gemini server
+Documentation=https://gmid.omarpolo.com/
+Documentation=man:gg(1) man:gmid(1)
+After=network-online.target syslog.target
+Wants=network-online.target
+
+[Service]
+Type=simple
+User=gmid
+Group=nobody
+ExecStart=/usr/bin/gmid -f -c /etc/gmid.conf
+ExecStop=/bin/kill -TERM $MAINPID
+ExecReload=/bin/kill -HUP $MAINPID
+Restart=on-failure
+RestartSec=30
+StandardOutput=journal
+StandardError=inherit
+SyslogIdentifier=gmid
+
+[Install]
+WantedBy=multi-user.target