summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2021-01-28 16:50:08 +1000
committerMark Blakeney2021-01-28 16:50:08 +1000
commitdfa3b5ad94cd4a98265de4cff0620566e007da4f (patch)
treeae1b3c4f370092f2ff82b2ecbc7e5ed426b5b7b8
parentfb77a0907a4c74bbc1e8c541a2ec352d374ab49b (diff)
downloadaur-dfa3b5ad94cd4a98265de4cff0620566e007da4f.tar.gz
Update to 1.13
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
2 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65f0ea0f0fed..319fea803b5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = vim-plugins-profiler
pkgdesc = Utility to output a sorted list of VIM plugin startup times in millisec.
- pkgver = 1.12
+ pkgver = 1.13
pkgrel = 1
url = https://github.com/bulletmark/vim-plugins-profiler
arch = any
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-wheel
depends = python>=3.5
- source = vim-plugins-profiler-1.12.tar.gz::https://github.com/bulletmark/vim-plugins-profiler/archive/1.12.tar.gz
- md5sums = 49dc0ca4bf4f6290b14153b4254a74a8
+ source = vim-plugins-profiler-1.13.tar.gz::https://github.com/bulletmark/vim-plugins-profiler/archive/1.13.tar.gz
+ md5sums = cc5f1086ce2dba7d800356ca9d3909ab
pkgname = vim-plugins-profiler
diff --git a/PKGBUILD b/PKGBUILD
index f174e301463d..e62e4133b82a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,38 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=vim-plugins-profiler
-pkgver=1.12
+pkgver=1.13
pkgrel=1
pkgdesc="Utility to output a sorted list of VIM plugin startup times in millisec."
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
depends=("python>=3.5")
-makedepends=("python-setuptools")
+makedepends=("python-pip" "python-wheel")
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-md5sums=('49dc0ca4bf4f6290b14153b4254a74a8')
+md5sums=('cc5f1086ce2dba7d800356ca9d3909ab')
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver"
+
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --root="$pkgdir" \
+ --isolated \
+ --ignore-installed \
+ --no-deps \
+ --disable-pip-version-check \
+ --no-python-version-warning \
+ --no-warn-script-location \
+ --no-cache-dir \
+ --no-compile \
+ --progress-bar=off \
+ .
+
+ local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
+ local _pkgname="${pkgname//-/_}"
+ cd "$pkgdir/$pdir"
+ rm -f $_pkgname-*.dist-info/direct_url.json
+ sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
+ python -O -m compileall -q .
}
# vim:set ts=2 sw=2 et: